diff mbox series

[OpenWrt-Devel] lua: fix build with MacOS's make

Message ID 20190628094102.32434-1-zajec5@gmail.com
State Accepted
Delegated to: Rafał Miłecki
Headers show
Series [OpenWrt-Devel] lua: fix build with MacOS's make | expand

Commit Message

Rafał Miłecki June 28, 2019, 9:41 a.m. UTC
From: Rafał Miłecki <rafal@milecki.pl>

It apparently requires passing V variable explicitly.

Fixes: fe59b46ca7e0 ("lua: include version number in installed files")
Reported-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---
 .../lua/patches-host/001-include-version-number.patch    | 9 +++++++++
 .../utils/lua/patches/001-include-version-number.patch   | 9 +++++++++
 2 files changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/package/utils/lua/patches-host/001-include-version-number.patch b/package/utils/lua/patches-host/001-include-version-number.patch
index b7056fd47c..f769e60736 100644
--- a/package/utils/lua/patches-host/001-include-version-number.patch
+++ b/package/utils/lua/patches-host/001-include-version-number.patch
@@ -24,6 +24,15 @@  diff --git a/Makefile b/Makefile
  
  # Lua version and release.
  V= 5.1
+@@ -53,7 +53,7 @@ R= 5.1.5
+ all:	$(PLAT)
+ 
+ $(PLATS) clean:
+-	cd src && $(MAKE) $@
++	cd src && $(MAKE) $@ V=$V
+ 
+ test:	dummy
+ 	src/lua test/hello.lua
 diff --git a/doc/lua.1 b/doc/lua5.1.1
 rename from doc/lua.1
 rename to doc/lua5.1.1
diff --git a/package/utils/lua/patches/001-include-version-number.patch b/package/utils/lua/patches/001-include-version-number.patch
index b7056fd47c..f769e60736 100644
--- a/package/utils/lua/patches/001-include-version-number.patch
+++ b/package/utils/lua/patches/001-include-version-number.patch
@@ -24,6 +24,15 @@  diff --git a/Makefile b/Makefile
  
  # Lua version and release.
  V= 5.1
+@@ -53,7 +53,7 @@ R= 5.1.5
+ all:	$(PLAT)
+ 
+ $(PLATS) clean:
+-	cd src && $(MAKE) $@
++	cd src && $(MAKE) $@ V=$V
+ 
+ test:	dummy
+ 	src/lua test/hello.lua
 diff --git a/doc/lua.1 b/doc/lua5.1.1
 rename from doc/lua.1
 rename to doc/lua5.1.1