diff mbox series

[OpenWrt-Devel,4/6] tools/autoconf, tools/quilt: Use default Host/Compile and Host/Install

Message ID 20190614183534.14768-4-jeffery.to@gmail.com
State Changes Requested
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel,1/6] build: Add auto file tracking / uninstall for Host/Install | expand

Commit Message

Jeffery To June 14, 2019, 6:35 p.m. UTC
Since bash is used for all submake processes, it isn't necessary to
override Host/Compile and Host/Install to explicitly set SHELL=bash.

Using the default Host/Install also allows their files to be
automatically tracked and uninstalled.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
---
 tools/autoconf/Makefile | 13 -------------
 tools/quilt/Makefile    | 13 ++-----------
 2 files changed, 2 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index 6eb64d77d5..671564337f 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -21,17 +21,4 @@  HOST_CONFIGURE_ARGS += \
 HOST_CONFIGURE_VARS += \
 	PERL="/usr/bin/env perl"
 
-define Host/Compile
-	export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
-	export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
-	-export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
-	$(call Host/Clean/Default)
-endef
-
 $(eval $(call HostBuild))
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index d0532b5984..e8f1a7a05f 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -21,16 +21,7 @@  define Host/Configure
 	[ -f $(HOST_BUILD_DIR)/Makefile ]
 endef
 
-define Host/Compile
-	$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all
-endef
-
-define Host/Install
-	$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" install
-endef
-
-define Host/Clean
-	rm -f $(STAGING_DIR_HOST)/bin/quilt
-endef
+HOST_MAKE_INSTALL_FLAGS += \
+	BUILD_ROOT="$(HOST_INSTALL_DIR)"
 
 $(eval $(call HostBuild))