diff mbox series

[OpenWrt-Devel,RFC] ath79: add support for COMFAST CF-E313AC

Message ID 20190319123312.10567-1-roger.pueyo@guifi.net
State Superseded
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel,RFC] ath79: add support for COMFAST CF-E313AC | expand

Commit Message

Roger Pueyo Centelles | Guifi.net March 19, 2019, 12:33 p.m. UTC
Hi,

I've just added support for the COMFAST CF-E313AC, an  outdoor wireless
CPE with two Ethernet ports and a 802.11ac radio (see patch below).

Everything is working fine but I've got two issues for which I'd like to
get some advise:

1) target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata

   I had to add "rm /lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin", since
   the driver tries to board-2.bin (the default calibration data from the
   firmware package) first and, when that file is not found, falls back to
   board.bin (the calibration data read from the flash).

   I haven't seen this on any other device, so I guess there must be a more
   elegant way to deal with it. Any idea?

2) target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts

   The device is equipped with a "w25q128" flash chip (16384 Kbytes) but the
   stock firmware image only used half of it (nvram partition finishes at
   0x000000800000, i.e., 8192 Kbytes):

   *** stock firmware bootlog ***
    [...]
   [    0.730000] 0x000000000000-0x000000010000 : "u-boot"
   [    0.740000] 0x000000010000-0x000000020000 : "art"
   [    0.740000] 0x000000020000-0x0000001a0000 : "kernel"
   [    0.750000] 0x0000001a0000-0x0000007e0000 : "rootfs"
   [    0.760000] mtd: device 3 (rootfs) set to be root filesystem
   [    0.760000] 1 squashfs-split partitions found on MTD device rootfs
   [    0.770000] 0x0000006c0000-0x0000007e0000 : "rootfs_data"
   [    0.780000] 0x0000007e0000-0x0000007f0000 : "configs"
   [    0.780000] 0x0000007f0000-0x000000800000 : "nvram"
   [    0.790000] 0x000000020000-0x0000007e0000 : "firmware"
    [...]

   Is there a way to use the remaining half of the flash?


Any comments regarding these or other issues will be highly appreciated.

Thanks!



---
 .../ath79/base-files/etc/board.d/01_leds      |   9 ++
 .../etc/hotplug.d/firmware/11-ath10k-caldata  |   7 +
 .../ath79/dts/qca9531_comfast_cf-e313ac.dts   | 143 ++++++++++++++++++
 target/linux/ath79/image/generic.mk           |   8 +
 4 files changed, 167 insertions(+)
 create mode 100644 target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts

Comments

Roger Pueyo Centelles | Guifi.net April 2, 2019, 1:37 p.m. UTC | #1
Hi,

Sorry for the inconvenience, but I'd like to insist on this topic since
it didn't get much traction on the first attempt.

I mostly succeeded in adding support for the COMFAST CF-E313AC devices,
but I ran into a couple of issues:

1) I need to remove the board-2.bin file shipped with the
ath10k-firmware-qca9888-ct so that the driver uses the actual
calibration data from the flash, dumped to board.bin (see [1]
<https://github.com/openwrt/openwrt/pull/1942/commits/9028a627bb9eb39ba74c9273cdf393bcd12c30cb#diff-8c41cbed377d406698f49b82d78a2057>)

2) the device has a 16MB SPI flash chip, but the stock firmware only
uses the first 8 MB, so I'm wasting the remaining 8 MB


I'd appreciate any comment on the topic. I also opened a pull request
(see [2] <https://github.com/openwrt/openwrt/pull/1942>) at GitHub,
where you're also very welcome to share your thoughts.

Thanks,

Roger


[1]
https://github.com/openwrt/openwrt/pull/1942/commits/9028a627bb9eb39ba74c9273cdf393bcd12c30cb#diff-8c41cbed377d406698f49b82d78a2057

[2] https://github.com/openwrt/openwrt/pull/1942

El 19/3/19 a les 13:33, Roger Pueyo Centelles ha escrit:
> Hi,
>
> I've just added support for the COMFAST CF-E313AC, an  outdoor wireless
> CPE with two Ethernet ports and a 802.11ac radio (see patch below).
>
> Everything is working fine but I've got two issues for which I'd like to
> get some advise:
>
> 1) target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
>
>    I had to add "rm /lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin", since
>    the driver tries to board-2.bin (the default calibration data from the
>    firmware package) first and, when that file is not found, falls back to
>    board.bin (the calibration data read from the flash).
>
>    I haven't seen this on any other device, so I guess there must be a more
>    elegant way to deal with it. Any idea?
>
> 2) target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
>
>    The device is equipped with a "w25q128" flash chip (16384 Kbytes) but the
>    stock firmware image only used half of it (nvram partition finishes at
>    0x000000800000, i.e., 8192 Kbytes):
>
>    *** stock firmware bootlog ***
>     [...]
>    [    0.730000] 0x000000000000-0x000000010000 : "u-boot"
>    [    0.740000] 0x000000010000-0x000000020000 : "art"
>    [    0.740000] 0x000000020000-0x0000001a0000 : "kernel"
>    [    0.750000] 0x0000001a0000-0x0000007e0000 : "rootfs"
>    [    0.760000] mtd: device 3 (rootfs) set to be root filesystem
>    [    0.760000] 1 squashfs-split partitions found on MTD device rootfs
>    [    0.770000] 0x0000006c0000-0x0000007e0000 : "rootfs_data"
>    [    0.780000] 0x0000007e0000-0x0000007f0000 : "configs"
>    [    0.780000] 0x0000007f0000-0x000000800000 : "nvram"
>    [    0.790000] 0x000000020000-0x0000007e0000 : "firmware"
>     [...]
>
>    Is there a way to use the remaining half of the flash?
>
>
> Any comments regarding these or other issues will be highly appreciated.
>
> Thanks!
>
>
>
> ---
>  .../ath79/base-files/etc/board.d/01_leds      |   9 ++
>  .../etc/hotplug.d/firmware/11-ath10k-caldata  |   7 +
>  .../ath79/dts/qca9531_comfast_cf-e313ac.dts   | 143 ++++++++++++++++++
>  target/linux/ath79/image/generic.mk           |   8 +
>  4 files changed, 167 insertions(+)
>  create mode 100644 target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
>
> diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
> index db5a6a4578..50c9ca2a8d 100755
> --- a/target/linux/ath79/base-files/etc/board.d/01_leds
> +++ b/target/linux/ath79/base-files/etc/board.d/01_leds
> @@ -47,6 +47,15 @@ comfast,cf-e120a-v3)
>  	ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssimediumhigh" "wlan0" "51" "100"
>  	ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssihigh" "wlan0" "76" "100"
>  	;;
> +comfast,cf-e313ac)
> +	ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
> +	ucidef_set_led_switch "wan" "WAN" "$boardname:green:wan" "switch0" "0x02"
> +	ucidef_set_rssimon "wlan0" "200000" "1"
> +	ucidef_set_led_rssi "rssilow" "RSSILOW" "$boardname:red:rssilow" "wlan0" "1" "100"
> +	ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "$boardname:red:rssimediumlow" "wlan0" "26" "100"
> +	ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssimediumhigh" "wlan0" "51" "100"
> +	ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssihigh" "wlan0" "76" "100"
> +	;;
>  dlink,dir-859-a1)
>  	ucidef_set_led_switch "internet" "WAN" "$boardname:green:internet" "switch0" "0x20"
>  	;;
> diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
> index 8651c97099..3096c4e1e8 100644
> --- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
> +++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
> @@ -162,6 +162,13 @@ case "$FIRMWARE" in
>  	;;
>  "ath10k/pre-cal-pci-0000:00:00.0.bin")
>  	case $board in
> +	comfast,cf-e313ac)
> +		ath10kcal_extract "art" 20480 12064
> +		ath10kcal_patch_mac_crc $(mtd_get_mac_binary art 4098)
> +		ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
> +			/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
> +		rm /lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin
> +		;;
>  	phicomm,k2t)
>  		ath10kcal_extract "art" 20480 12064
>  		ath10kcal_patch_mac_crc $(k2t_get_mac "5g_mac")
> diff --git a/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts b/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
> new file mode 100644
> index 0000000000..cf6587b615
> --- /dev/null
> +++ b/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
> @@ -0,0 +1,143 @@
> +// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
> +/dts-v1/;
> +
> +#include <dt-bindings/gpio/gpio.h>
> +#include <dt-bindings/input/input.h>
> +
> +#include "qca953x.dtsi"
> +
> +/ {
> +	compatible = "comfast,cf-e313ac", "qca,qca9531";
> +	model = "COMFAST CF-E313AC";
> +
> +	aliases {
> +		serial0 = &uart;
> +		led-boot = &wan;
> +		led-failsafe = &wan;
> +		led-upgrade = &wan;
> +	};
> +
> +	leds {
> +		compatible = "gpio-leds";
> +
> +		pinctrl-names = "default";
> +
> +		wan: wan {
> +			label = "cf-e313ac:green:wan";
> +			gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
> +		};
> +
> +		lan: lan {
> +			label = "cf-e313ac:green:lan";
> +			gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
> +		};
> +
> +		wlan: wlan {
> +			label = "cf-e313ac:green:wlan";
> +			gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
> +			linux,default-trigger = "phy0tpt";
> +		};
> +
> +		rssilow {
> +			label = "cf-e313ac:red:rssilow";
> +			gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
> +		};
> +
> +		rssimediumlow {
> +			label = "cf-e313ac:red:rssimediumlow";
> +			gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
> +		};
> +
> +		rssimediumhigh {
> +			label = "cf-e313ac:green:rssimediumhigh";
> +			gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
> +		};
> +
> +		rssihigh {
> +			label = "cf-e313ac:green:rssihigh";
> +			gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
> +		};
> +	};
> +
> +	keys {
> +		compatible = "gpio-keys-polled";
> +		poll-interval = <20>;
> +
> +		reset {
> +			label = "reset";
> +			linux,code = <KEY_RESTART>;
> +			gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
> +			debounce-interval = <60>;
> +		};
> +	};
> +};
> +
> +&spi {
> +	status = "okay";
> +	num-cs = <1>;
> +
> +	flash@0 {
> +		compatible = "jedec,spi-nor";
> +		reg = <0>;
> +		spi-max-frequency = <25000000>;
> +
> +		partitions {
> +			compatible = "fixed-partitions";
> +			#address-cells = <1>;
> +			#size-cells = <1>;
> +
> +			partition@0 {
> +				label = "u-boot";
> +				reg = <0x000000 0x010000>;
> +				read-only;
> +			};
> +
> +			art: partition@10000 {
> +				label = "art";
> +				reg = <0x010000 0x010000>;
> +				read-only;
> +			};
> +
> +			partition@20000 {
> +				compatible = "denx,uimage";
> +				label = "firmware";
> +				reg = <0x020000 0x7c0000>;
> +			};
> +
> +			partition@7e0000 {
> +				label = "configs";
> +				reg = <0x7e0000 0x010000>;
> +				read-only;
> +			};
> +
> +			partition@7f0000 {
> +				label = "nvram";
> +				reg = <0x7f0000 0x010000>;
> +				read-only;
> +			};
> +		};
> +	};
> +};
> +
> +&uart {
> +	status = "okay";
> +};
> +
> +&eth0 {
> +	status = "okay";
> +	mtd-mac-address = <&art 0x0>;
> +	phy-handle = <&swphy4>;
> +};
> +
> +&eth1 {
> +	status = "okay";
> +	mtd-mac-address = <&art 0x6>;
> +
> +	gmac-config {
> +		device = <&gmac>;
> +	};
> +};
> +
> +&pcie0 {
> +	status = "okay";
> +};
> diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
> index ddf0e62898..69a29ab8fd 100644
> --- a/target/linux/ath79/image/generic.mk
> +++ b/target/linux/ath79/image/generic.mk
> @@ -171,6 +171,14 @@ define Device/comfast_cf-e120a-v3
>  endef
>  TARGET_DEVICES += comfast_cf-e120a-v3
>  
> +define Device/comfast_cf-e313ac
> +  ATH_SOC := qca9531
> +  DEVICE_TITLE := COMFAST CF-E313AC
> +  DEVICE_PACKAGES := rssileds kmod-leds-gpio kmod-ath10k-ct ath10k-firmware-qca9888-ct
> +  IMAGE_SIZE := 8000k
> +endef
> +TARGET_DEVICES += comfast_cf-e313ac
> +
>  define Device/devolo_dvl1200e
>    ATH_SOC := qca9558
>    DEVICE_TITLE := devolo WiFi pro 1200e
<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <p>Hi,</p>
    <p>Sorry for the inconvenience, but I'd like to insist on this topic
      since it didn't get much traction on the first attempt.</p>
    <p>I mostly succeeded in adding support for the COMFAST CF-E313AC
      devices, but I ran into a couple of issues:</p>
    <p>1) I need to remove the board-2.bin file shipped with the
      ath10k-firmware-qca9888-ct so that the driver uses the actual
      calibration data from the flash, dumped to board.bin (<a
        moz-do-not-send="true"
href="https://github.com/openwrt/openwrt/pull/1942/commits/9028a627bb9eb39ba74c9273cdf393bcd12c30cb#diff-8c41cbed377d406698f49b82d78a2057">see
        [1]</a>)</p>
    <p>2) the device has a 16MB SPI flash chip, but the stock firmware
      only uses the first 8 MB, so I'm wasting the remaining 8 MB</p>
    <p><br>
    </p>
    <p>I'd appreciate any comment on the topic. I also opened a pull
      request (<a moz-do-not-send="true"
        href="https://github.com/openwrt/openwrt/pull/1942">see [2]</a>)
      at GitHub, where you're also very welcome to share your thoughts.<br>
    </p>
    <p>Thanks,</p>
    <p>Roger</p>
    <p><br>
    </p>
    <p>[1]
<a class="moz-txt-link-freetext" href="https://github.com/openwrt/openwrt/pull/1942/commits/9028a627bb9eb39ba74c9273cdf393bcd12c30cb#diff-8c41cbed377d406698f49b82d78a2057">https://github.com/openwrt/openwrt/pull/1942/commits/9028a627bb9eb39ba74c9273cdf393bcd12c30cb#diff-8c41cbed377d406698f49b82d78a2057</a></p>
    <p>[2] <a class="moz-txt-link-freetext" href="https://github.com/openwrt/openwrt/pull/1942">https://github.com/openwrt/openwrt/pull/1942</a><br>
    </p>
    <div class="moz-cite-prefix">El 19/3/19 a les 13:33, Roger Pueyo
      Centelles ha escrit:<br>
    </div>
    <blockquote type="cite"
      cite="mid:20190319123312.10567-1-roger.pueyo@guifi.net">
      <pre class="moz-quote-pre" wrap="">Hi,

I've just added support for the COMFAST CF-E313AC, an  outdoor wireless
CPE with two Ethernet ports and a 802.11ac radio (see patch below).

Everything is working fine but I've got two issues for which I'd like to
get some advise:

1) target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata

   I had to add "rm /lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin", since
   the driver tries to board-2.bin (the default calibration data from the
   firmware package) first and, when that file is not found, falls back to
   board.bin (the calibration data read from the flash).

   I haven't seen this on any other device, so I guess there must be a more
   elegant way to deal with it. Any idea?

2) target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts

   The device is equipped with a "w25q128" flash chip (16384 Kbytes) but the
   stock firmware image only used half of it (nvram partition finishes at
   0x000000800000, i.e., 8192 Kbytes):

   *** stock firmware bootlog ***
    [...]
   [    0.730000] 0x000000000000-0x000000010000 : "u-boot"
   [    0.740000] 0x000000010000-0x000000020000 : "art"
   [    0.740000] 0x000000020000-0x0000001a0000 : "kernel"
   [    0.750000] 0x0000001a0000-0x0000007e0000 : "rootfs"
   [    0.760000] mtd: device 3 (rootfs) set to be root filesystem
   [    0.760000] 1 squashfs-split partitions found on MTD device rootfs
   [    0.770000] 0x0000006c0000-0x0000007e0000 : "rootfs_data"
   [    0.780000] 0x0000007e0000-0x0000007f0000 : "configs"
   [    0.780000] 0x0000007f0000-0x000000800000 : "nvram"
   [    0.790000] 0x000000020000-0x0000007e0000 : "firmware"
    [...]

   Is there a way to use the remaining half of the flash?


Any comments regarding these or other issues will be highly appreciated.

Thanks!



---
 .../ath79/base-files/etc/board.d/01_leds      |   9 ++
 .../etc/hotplug.d/firmware/11-ath10k-caldata  |   7 +
 .../ath79/dts/qca9531_comfast_cf-e313ac.dts   | 143 ++++++++++++++++++
 target/linux/ath79/image/generic.mk           |   8 +
 4 files changed, 167 insertions(+)
 create mode 100644 target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts

diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index db5a6a4578..50c9ca2a8d 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -47,6 +47,15 @@ comfast,cf-e120a-v3)
 	ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssimediumhigh" "wlan0" "51" "100"
 	ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssihigh" "wlan0" "76" "100"
 	;;
+comfast,cf-e313ac)
+	ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
+	ucidef_set_led_switch "wan" "WAN" "$boardname:green:wan" "switch0" "0x02"
+	ucidef_set_rssimon "wlan0" "200000" "1"
+	ucidef_set_led_rssi "rssilow" "RSSILOW" "$boardname:red:rssilow" "wlan0" "1" "100"
+	ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "$boardname:red:rssimediumlow" "wlan0" "26" "100"
+	ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssimediumhigh" "wlan0" "51" "100"
+	ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssihigh" "wlan0" "76" "100"
+	;;
 dlink,dir-859-a1)
 	ucidef_set_led_switch "internet" "WAN" "$boardname:green:internet" "switch0" "0x20"
 	;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 8651c97099..3096c4e1e8 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -162,6 +162,13 @@ case "$FIRMWARE" in
 	;;
 "ath10k/pre-cal-pci-0000:00:00.0.bin")
 	case $board in
+	comfast,cf-e313ac)
+		ath10kcal_extract "art" 20480 12064
+		ath10kcal_patch_mac_crc $(mtd_get_mac_binary art 4098)
+		ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
+			/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
+		rm /lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin
+		;;
 	phicomm,k2t)
 		ath10kcal_extract "art" 20480 12064
 		ath10kcal_patch_mac_crc $(k2t_get_mac "5g_mac")
diff --git a/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts b/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
new file mode 100644
index 0000000000..cf6587b615
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
@@ -0,0 +1,143 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include &lt;dt-bindings/gpio/gpio.h&gt;
+#include &lt;dt-bindings/input/input.h&gt;
+
+#include "qca953x.dtsi"
+
+/ {
+	compatible = "comfast,cf-e313ac", "qca,qca9531";
+	model = "COMFAST CF-E313AC";
+
+	aliases {
+		serial0 = &amp;uart;
+		led-boot = &amp;wan;
+		led-failsafe = &amp;wan;
+		led-upgrade = &amp;wan;
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		pinctrl-names = "default";
+
+		wan: wan {
+			label = "cf-e313ac:green:wan";
+			gpios = &lt;&amp;gpio 0 GPIO_ACTIVE_LOW&gt;;
+		};
+
+		lan: lan {
+			label = "cf-e313ac:green:lan";
+			gpios = &lt;&amp;gpio 2 GPIO_ACTIVE_LOW&gt;;
+		};
+
+		wlan: wlan {
+			label = "cf-e313ac:green:wlan";
+			gpios = &lt;&amp;gpio 3 GPIO_ACTIVE_LOW&gt;;
+			linux,default-trigger = "phy0tpt";
+		};
+
+		rssilow {
+			label = "cf-e313ac:red:rssilow";
+			gpios = &lt;&amp;gpio 11 GPIO_ACTIVE_LOW&gt;;
+		};
+
+		rssimediumlow {
+			label = "cf-e313ac:red:rssimediumlow";
+			gpios = &lt;&amp;gpio 12 GPIO_ACTIVE_LOW&gt;;
+		};
+
+		rssimediumhigh {
+			label = "cf-e313ac:green:rssimediumhigh";
+			gpios = &lt;&amp;gpio 14 GPIO_ACTIVE_LOW&gt;;
+		};
+
+		rssihigh {
+			label = "cf-e313ac:green:rssihigh";
+			gpios = &lt;&amp;gpio 16 GPIO_ACTIVE_LOW&gt;;
+		};
+	};
+
+	keys {
+		compatible = "gpio-keys-polled";
+		poll-interval = &lt;20&gt;;
+
+		reset {
+			label = "reset";
+			linux,code = &lt;KEY_RESTART&gt;;
+			gpios = &lt;&amp;gpio 17 GPIO_ACTIVE_LOW&gt;;
+			debounce-interval = &lt;60&gt;;
+		};
+	};
+};
+
+&amp;spi {
+	status = "okay";
+	num-cs = &lt;1&gt;;
+
+	flash@0 {
+		compatible = "jedec,spi-nor";
+		reg = &lt;0&gt;;
+		spi-max-frequency = &lt;25000000&gt;;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = &lt;1&gt;;
+			#size-cells = &lt;1&gt;;
+
+			partition@0 {
+				label = "u-boot";
+				reg = &lt;0x000000 0x010000&gt;;
+				read-only;
+			};
+
+			art: partition@10000 {
+				label = "art";
+				reg = &lt;0x010000 0x010000&gt;;
+				read-only;
+			};
+
+			partition@20000 {
+				compatible = "denx,uimage";
+				label = "firmware";
+				reg = &lt;0x020000 0x7c0000&gt;;
+			};
+
+			partition@7e0000 {
+				label = "configs";
+				reg = &lt;0x7e0000 0x010000&gt;;
+				read-only;
+			};
+
+			partition@7f0000 {
+				label = "nvram";
+				reg = &lt;0x7f0000 0x010000&gt;;
+				read-only;
+			};
+		};
+	};
+};
+
+&amp;uart {
+	status = "okay";
+};
+
+&amp;eth0 {
+	status = "okay";
+	mtd-mac-address = &lt;&amp;art 0x0&gt;;
+	phy-handle = &lt;&amp;swphy4&gt;;
+};
+
+&amp;eth1 {
+	status = "okay";
+	mtd-mac-address = &lt;&amp;art 0x6&gt;;
+
+	gmac-config {
+		device = &lt;&amp;gmac&gt;;
+	};
+};
+
+&amp;pcie0 {
+	status = "okay";
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ddf0e62898..69a29ab8fd 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -171,6 +171,14 @@ define Device/comfast_cf-e120a-v3
 endef
 TARGET_DEVICES += comfast_cf-e120a-v3
 
+define Device/comfast_cf-e313ac
+  ATH_SOC := qca9531
+  DEVICE_TITLE := COMFAST CF-E313AC
+  DEVICE_PACKAGES := rssileds kmod-leds-gpio kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  IMAGE_SIZE := 8000k
+endef
+TARGET_DEVICES += comfast_cf-e313ac
+
 define Device/devolo_dvl1200e
   ATH_SOC := qca9558
   DEVICE_TITLE := devolo WiFi pro 1200e
</pre>
    </blockquote>
  
<br>
<br>
</body>
</html>
diff mbox series

Patch

diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index db5a6a4578..50c9ca2a8d 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -47,6 +47,15 @@  comfast,cf-e120a-v3)
 	ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssimediumhigh" "wlan0" "51" "100"
 	ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssihigh" "wlan0" "76" "100"
 	;;
+comfast,cf-e313ac)
+	ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
+	ucidef_set_led_switch "wan" "WAN" "$boardname:green:wan" "switch0" "0x02"
+	ucidef_set_rssimon "wlan0" "200000" "1"
+	ucidef_set_led_rssi "rssilow" "RSSILOW" "$boardname:red:rssilow" "wlan0" "1" "100"
+	ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "$boardname:red:rssimediumlow" "wlan0" "26" "100"
+	ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssimediumhigh" "wlan0" "51" "100"
+	ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssihigh" "wlan0" "76" "100"
+	;;
 dlink,dir-859-a1)
 	ucidef_set_led_switch "internet" "WAN" "$boardname:green:internet" "switch0" "0x20"
 	;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 8651c97099..3096c4e1e8 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -162,6 +162,13 @@  case "$FIRMWARE" in
 	;;
 "ath10k/pre-cal-pci-0000:00:00.0.bin")
 	case $board in
+	comfast,cf-e313ac)
+		ath10kcal_extract "art" 20480 12064
+		ath10kcal_patch_mac_crc $(mtd_get_mac_binary art 4098)
+		ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
+			/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
+		rm /lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin
+		;;
 	phicomm,k2t)
 		ath10kcal_extract "art" 20480 12064
 		ath10kcal_patch_mac_crc $(k2t_get_mac "5g_mac")
diff --git a/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts b/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
new file mode 100644
index 0000000000..cf6587b615
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_comfast_cf-e313ac.dts
@@ -0,0 +1,143 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+	compatible = "comfast,cf-e313ac", "qca,qca9531";
+	model = "COMFAST CF-E313AC";
+
+	aliases {
+		serial0 = &uart;
+		led-boot = &wan;
+		led-failsafe = &wan;
+		led-upgrade = &wan;
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		pinctrl-names = "default";
+
+		wan: wan {
+			label = "cf-e313ac:green:wan";
+			gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+		};
+
+		lan: lan {
+			label = "cf-e313ac:green:lan";
+			gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+		};
+
+		wlan: wlan {
+			label = "cf-e313ac:green:wlan";
+			gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+			linux,default-trigger = "phy0tpt";
+		};
+
+		rssilow {
+			label = "cf-e313ac:red:rssilow";
+			gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+		};
+
+		rssimediumlow {
+			label = "cf-e313ac:red:rssimediumlow";
+			gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+		};
+
+		rssimediumhigh {
+			label = "cf-e313ac:green:rssimediumhigh";
+			gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+		};
+
+		rssihigh {
+			label = "cf-e313ac:green:rssihigh";
+			gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+		};
+	};
+
+	keys {
+		compatible = "gpio-keys-polled";
+		poll-interval = <20>;
+
+		reset {
+			label = "reset";
+			linux,code = <KEY_RESTART>;
+			gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+			debounce-interval = <60>;
+		};
+	};
+};
+
+&spi {
+	status = "okay";
+	num-cs = <1>;
+
+	flash@0 {
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <25000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x000000 0x010000>;
+				read-only;
+			};
+
+			art: partition@10000 {
+				label = "art";
+				reg = <0x010000 0x010000>;
+				read-only;
+			};
+
+			partition@20000 {
+				compatible = "denx,uimage";
+				label = "firmware";
+				reg = <0x020000 0x7c0000>;
+			};
+
+			partition@7e0000 {
+				label = "configs";
+				reg = <0x7e0000 0x010000>;
+				read-only;
+			};
+
+			partition@7f0000 {
+				label = "nvram";
+				reg = <0x7f0000 0x010000>;
+				read-only;
+			};
+		};
+	};
+};
+
+&uart {
+	status = "okay";
+};
+
+&eth0 {
+	status = "okay";
+	mtd-mac-address = <&art 0x0>;
+	phy-handle = <&swphy4>;
+};
+
+&eth1 {
+	status = "okay";
+	mtd-mac-address = <&art 0x6>;
+
+	gmac-config {
+		device = <&gmac>;
+	};
+};
+
+&pcie0 {
+	status = "okay";
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ddf0e62898..69a29ab8fd 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -171,6 +171,14 @@  define Device/comfast_cf-e120a-v3
 endef
 TARGET_DEVICES += comfast_cf-e120a-v3
 
+define Device/comfast_cf-e313ac
+  ATH_SOC := qca9531
+  DEVICE_TITLE := COMFAST CF-E313AC
+  DEVICE_PACKAGES := rssileds kmod-leds-gpio kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  IMAGE_SIZE := 8000k
+endef
+TARGET_DEVICES += comfast_cf-e313ac
+
 define Device/devolo_dvl1200e
   ATH_SOC := qca9558
   DEVICE_TITLE := devolo WiFi pro 1200e