diff mbox series

[OpenWrt-Devel,03/11] tools/popt: new package

Message ID 20190311162028.13172-4-thomas.petazzoni@bootlin.com
State Superseded
Headers show
Series Proposal for dm-verity support | expand

Commit Message

Thomas Petazzoni March 11, 2019, 4:20 p.m. UTC
popt for the host will be needed as a dependency of cryptsetup for the
host.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 tools/Makefile      |  2 +-
 tools/popt/Makefile | 22 ++++++++++++++++++++++
 2 files changed, 23 insertions(+), 1 deletion(-)
 create mode 100644 tools/popt/Makefile
diff mbox series

Patch

diff --git a/tools/Makefile b/tools/Makefile
index 0127fa6fda..4941fed38d 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -27,7 +27,7 @@  tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image quilt padjffs2
 tools-y += mm-macros missing-macros cmake scons bc findutils gengetopt patchelf
 tools-y += mtools dosfstools libressl
-tools-y += libaio lvm2
+tools-y += libaio lvm2 popt
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
diff --git a/tools/popt/Makefile b/tools/popt/Makefile
new file mode 100644
index 0000000000..7a6de9fa02
--- /dev/null
+++ b/tools/popt/Makefile
@@ -0,0 +1,22 @@ 
+#
+# Copyright (C) 2010-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=popt
+PKG_VERSION:=1.16
+PKG_HASH:=e728ed296fe9f069a0e005003c3d6b2dde3d9cad453422a10d6558616d304cc8
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://rpm5.org/files/popt
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))