diff mbox series

[OpenWrt-Devel,08/29] kernel: Deactivate *-gpio-custom drivers for 4.19

Message ID 20181209151451.8831-9-hauke@hauke-m.de
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series Add support for kernel 4.19 | expand

Commit Message

Hauke Mehrtens Dec. 9, 2018, 3:14 p.m. UTC
Kernel interface changed with kernel 4.19, it does not accept raw GPIO
numbers any more. Deactivate these drivers on kernel 4.19 for now.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 package/kernel/i2c-gpio-custom/Makefile | 2 +-
 package/kernel/spi-gpio-custom/Makefile | 2 +-
 package/kernel/w1-gpio-custom/Makefile  | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/package/kernel/i2c-gpio-custom/Makefile b/package/kernel/i2c-gpio-custom/Makefile
index d1123cc3fb..a0b86cc7ef 100644
--- a/package/kernel/i2c-gpio-custom/Makefile
+++ b/package/kernel/i2c-gpio-custom/Makefile
@@ -16,7 +16,7 @@  include $(INCLUDE_DIR)/package.mk
 define KernelPackage/i2c-gpio-custom
   SUBMENU:=I2C support
   TITLE:=Custom GPIO-based I2C device
-  DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +kmod-i2c-gpio
+  DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +kmod-i2c-gpio @!LINUX_4_19
   FILES:=$(PKG_BUILD_DIR)/i2c-gpio-custom.ko
   KCONFIG:=
 endef
diff --git a/package/kernel/spi-gpio-custom/Makefile b/package/kernel/spi-gpio-custom/Makefile
index 19aef20ed2..b0da3db188 100644
--- a/package/kernel/spi-gpio-custom/Makefile
+++ b/package/kernel/spi-gpio-custom/Makefile
@@ -16,7 +16,7 @@  include $(INCLUDE_DIR)/package.mk
 define KernelPackage/spi-gpio-custom
   SUBMENU:=SPI Support
   TITLE:=Custom GPIO-based SPI device
-  DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang +kmod-spi-gpio +kmod-spi-dev
+  DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang +kmod-spi-gpio +kmod-spi-dev @!LINUX_4_19
   FILES:=$(PKG_BUILD_DIR)/spi-gpio-custom.ko
   KCONFIG:=
 endef
diff --git a/package/kernel/w1-gpio-custom/Makefile b/package/kernel/w1-gpio-custom/Makefile
index 1008cf9736..662f65f001 100644
--- a/package/kernel/w1-gpio-custom/Makefile
+++ b/package/kernel/w1-gpio-custom/Makefile
@@ -16,7 +16,7 @@  include $(INCLUDE_DIR)/package.mk
 define KernelPackage/w1-gpio-custom
   SUBMENU:=W1 support
   TITLE:=Custom GPIO-based 1-wire device
-  DEPENDS:=kmod-w1 +kmod-w1-master-gpio
+  DEPENDS:=kmod-w1 +kmod-w1-master-gpio @!LINUX_4_19
   FILES:=$(PKG_BUILD_DIR)/w1-gpio-custom.ko
   KCONFIG:=
 endef