diff mbox series

[OpenWrt-Devel] gemini: Cook SQ201 images

Message ID 20180615213457.6277-1-linus.walleij@linaro.org
State Accepted
Headers show
Series [OpenWrt-Devel] gemini: Cook SQ201 images | expand

Commit Message

Linus Walleij June 15, 2018, 9:34 p.m. UTC
This generates the "rd.gz" and "hddapp.tgz" that doesn't contain
anything of the sort but rather the OpenWRT rootfs. It works the
same way as how we generate the same layout for the NAS4220b.
For some reason the ImageInfo file is different for the SQ201.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 target/linux/gemini/image/ImageInfo-sq201 | 18 ++++++++++++++++++
 target/linux/gemini/image/Makefile        | 17 +++++++++++++++++
 2 files changed, 35 insertions(+)
 create mode 100644 target/linux/gemini/image/ImageInfo-sq201
diff mbox series

Patch

diff --git a/target/linux/gemini/image/ImageInfo-sq201 b/target/linux/gemini/image/ImageInfo-sq201
new file mode 100644
index 000000000000..86040ab4708c
--- /dev/null
+++ b/target/linux/gemini/image/ImageInfo-sq201
@@ -0,0 +1,18 @@ 
+UpgradeImages="zImage rd.gz hddapp.tgz"
+Procduction="SL3516"
+BOOT_VER="1.0.5"
+FIRMWARE_VER="firmware-openwrt-DATESTR"
+INTERNAL_FIRMWARE_VER="firmware-openwrt-DATESTR"
+CONFIGURATION_VER="firmware-openwrt"
+DESCRIPTION="Square One Router/Nas"
+TSS="enabled"
+DIRECT_MODE="disabled"
+DEFAULT_LAN_IPADDR="192.168.1.1"
+DEFAULT_LAN_NETMASK="255.255.255.0"
+DEFAULT_LAN_BOOTPROTO="none"
+DEFAULT_WAN_BOOTPROTO="dhcp"
+DEFAULT_WAN_ENABLED="yes"
+DEFAULT_WLAN_DEVICENAME="eth0"
+VER_zImage="DATESTR"
+VER_Ramdisk="DATESTR"
+VER_hddapp="DATESTR"
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index ba2ee02bfa7d..a05b7111b5bc 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -54,6 +54,21 @@  define Build/nas4220b-images
 	rm -f $(BIN_DIR)/ImageInfo
 endef
 
+# The Itian Square One SQ201 uses the same method.
+define Build/sq201-images
+	dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
+	dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
+	cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
+	cp ./ImageInfo-sq201 $(BIN_DIR)/ImageInfo
+	sed -i -e "s/DATESTR/`date +%Y%m%d`/g" $(BIN_DIR)/ImageInfo
+	(cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-sq201.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
+	mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-sq201-rd.gz
+	mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-sq201-hddapp.tgz
+	mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-sq201-zImage
+	rm -f $(BIN_DIR)/ImageInfo
+endef
+
+
 # WBD-111 and WBD-222:
 # work around the bootloader's bug with extra nops
 # FIXME: is this really needed now that we no longer append the code
@@ -120,6 +135,8 @@  TARGET_DEVICES += rut1xx
 
 define Device/sq201
 	DEVICE_TITLE := ITian Square One SQ201
+	IMAGES += sq201-image
+	IMAGE/sq201-image := sq201-images
 	DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci
 endef
 TARGET_DEVICES += sq201