diff mbox

[OpenWrt-Devel] kernel: Support kernel options required by systemd

Message ID 20150314135544.GA6429@ubuntu
State Accepted
Headers show

Commit Message

Jeff Waugh March 14, 2015, 1:55 p.m. UTC
These kernel options are all likely to be widely useful in this modern age, but
are immediately useful for systemd support.

c.f. http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild?&view=markup#l118

Adapted from a patch by Adam Porter.

Signed-off-by: Jeff Waugh <jdub@bethesignal.org>
---
 config/Config-kernel.in | 34 ++++++++++++++++++++++++++++------
 1 file changed, 28 insertions(+), 6 deletions(-)
diff mbox

Patch

diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 34e07bd..ae5b3d5 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -115,6 +115,18 @@  config KERNEL_DIRECT_IO
 	bool "Compile the kernel with direct IO support"
 	default n
 
+config KERNEL_FHANDLE
+	bool "Compile the kernel with support for fhandle syscalls"
+	default n
+
+config KERNEL_FANOTIFY
+	bool "Compile the kernel with modern file notification support"
+	default n
+
+config KERNEL_BLK_DEV_BSG
+	bool "Compile the kernel with SCSI generic v4 support for any block device"
+	default n
+
 config KERNEL_MAGIC_SYSRQ
 	bool "Compile the kernel with SysRq support"
 	default y
@@ -164,6 +176,22 @@  config USE_SPARSE
 	bool "Enable sparse check during kernel build"
 	default n
 
+config KERNEL_DEVTMPFS
+	bool "Compile the kernel with device tmpfs enabled"
+	default n
+	help
+	  devtmpfs is a simple, kernel-managed /dev filesystem. The kernel creates
+	  devices nodes for all registered devices ti simplify boot, but leaves more
+	  complex tasks to userspace (e.g. udev).
+
+if KERNEL_DEVTMPFS
+
+	config KERNEL_DEVTMPFS_MOUNT
+		bool "Automatically mount devtmpfs after root filesystem is mounted"
+		default n
+
+endif
+
 #
 # CGROUP support symbols
 #
@@ -481,9 +509,3 @@  config KERNEL_SECCOMP_FILTER
 		default n
 		help
 		  Build kernel with support for seccomp BPF programs.
-
-config KERNEL_FHANDLE
-	bool "Enable open by fhandle syscalls"
-		default n
-		help
-		  Build kernel with support for open by fhandle syscalls