diff mbox

[OpenWrt-Devel,packages] new package dansguardian

Message ID 20150118114518.GA6650@hanno-All-Series
State Rejected
Headers show

Commit Message

hanno Jan. 18, 2015, 11:45 a.m. UTC
Moved new version 2.12.03 from oldpackages to packages as request by Felix
Fietkau

Signed-off-by: Hanno Schupp <hanno.schupp@gmail.com>
---

Comments

Jiri Slachta Jan. 18, 2015, 11:50 a.m. UTC | #1
Hello Hanno,

openwrt-devel mailing list is intended to be used for patches against
the base OpenWrt repository. The packages repository has been moved
to github where all changes are merged as pull requests. 

See the statement about the transition to github:
	https://forum.openwrt.org/viewtopic.php?id=51078

The new packages repository is located here:
	http://github.com/openwrt/packages

Kind regards,
Jiri Slachta

Dne 18.1.2015 v 12:45 hanno napsal(a):
> Moved new version 2.12.03 from oldpackages to packages as request by Felix
> Fietkau
> 
> Signed-off-by: Hanno Schupp <hanno.schupp@gmail.com>
> ---
> diff -uprN ../trunk/feeds/packages/net/dansguardian/Makefile ./feeds/packages/net/dansguardian/Makefile
> --- ../trunk/feeds/packages/net/dansguardian/Makefile	1970-01-01 12:00:00.000000000 +1200
> +++ ./feeds/packages/net/dansguardian/Makefile	2015-01-06 15:56:14.017306000 +1300
> @@ -0,0 +1,62 @@
> +#
> +# Copyright (C) 2008-2009 OpenWrt.org
> +#
> +# This is free software, licensed under the GNU General Public License v2.
> +# See /LICENSE for more information.
> +#
> +
> +include $(TOPDIR)/rules.mk
> +
> +PKG_NAME:=dansguardian
> +PKG_VERSION:=2.12.0.3
> +PKG_RELEASE:=1
> +
> +PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
> +PKG_SOURCE_URL:=http://sourceforge.net/projects/dansguardian/files/
> +PKG_MD5SUM:=2a88d0392cd28eaec02b7ee727b2e253
> +
> +PKG_INSTALL:=1
> +
> +include $(INCLUDE_DIR)/uclibc++.mk
> +include $(INCLUDE_DIR)/package.mk
> +
> +define Package/dansguardian
> +  SECTION:=net
> +  DEPENDS:=+libpthread $(CXX_DEPENDS) +zlib
> +  CATEGORY:=Network
> +  SUBMENU:=Web Servers/Proxies
> +  TITLE:=DansGuardian
> +  URL:=http://dansguardian.org
> +endef
> +
> +define Package/dansguardian/conffiles
> +/etc/dansguardian/dansguardian.conf
> +endef
> +
> +CONFIGURE_VARS += \
> +	INCLUDES="" \
> +	CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
> +	LIBS="-lpthread" \
> +
> +define Build/Configure
> +	$(call Build/Configure/Default,\
> +		--disable-clamav \
> +		--with-sysconfsubdir=dansguardian \
> +		--with-proxyuser=root \
> +		--with-proxygroup=root \
> +		--disable-pcre \
> +	)
> +endef
> +
> +define Package/dansguardian/install
> +	$(INSTALL_DIR) $(1)/usr/sbin
> +	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dansguardian $(1)/usr/sbin/
> +	$(INSTALL_DIR) $(1)/etc
> +	$(CP) $(PKG_INSTALL_DIR)/etc/dansguardian $(1)/etc/
> +	$(INSTALL_DIR) $(1)/usr/share/dansguardian
> +	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/dansguardian/transparent1x1.gif $(1)/usr/share/dansguardian/
> +	$(INSTALL_DIR) $(1)/usr/share/dansguardian/languages/ukenglish
> +	$(CP) $(PKG_INSTALL_DIR)/usr/share/dansguardian/languages/ukenglish/* $(1)/usr/share/dansguardian/languages/ukenglish/
> +endef
> +
> +$(eval $(call BuildPackage,dansguardian))
> diff -uprN ../trunk/feeds/packages/net/dansguardian/patches/001-include_dir.patch ./feeds/packages/net/dansguardian/patches/001-include_dir.patch
> --- ../trunk/feeds/packages/net/dansguardian/patches/001-include_dir.patch	1970-01-01 12:00:00.000000000 +1200
> +++ ./feeds/packages/net/dansguardian/patches/001-include_dir.patch	2015-01-06 08:08:58.494773000 +1300
> @@ -0,0 +1,29 @@
> +--- a/configure
> ++++ b/configure
> +@@ -861,7 +861,7 @@ sysconfdir='${prefix}/etc'
> + sharedstatedir='${prefix}/com'
> + localstatedir='${prefix}/var'
> + includedir='${prefix}/include'
> +-oldincludedir='/usr/include'
> ++oldincludedir='${prefix}/usr/include'
> + docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
> + infodir='${datarootdir}/info'
> + htmldir='${docdir}'
> +@@ -6317,7 +6317,7 @@ $as_echo_n "checking for zlib... " >&6; 
> + # Check whether --with-zlib was given.
> + if test "${with_zlib+set}" = set; then
> +   withval=$with_zlib;  # check for header & func (in library) in given prefix
> +-	CPPFLAGS="${CPPFLAGS} -I${withval}/include"
> ++	CPPFLAGS="${CPPFLAGS}"
> + 	if test "x$staticzlib" = "xtrue"; then
> + 		LIBS="-Bstatic -L${withval} -lz -Bdynamic ${LIBS}"
> + 	else
> +@@ -10042,7 +10042,7 @@ _ACEOF
> + if test "${with_libiconv+set}" = set; then
> +   withval=$with_libiconv;  # check for header & func (in library) in given prefix
> + 			if test "x$withval" != "x"; then
> +-				CPPFLAGS="${CPPFLAGS} -I${withval}/include"
> ++				CPPFLAGS="${CPPFLAGS}"
> + 				LIBS="-L${withval}/lib -liconv ${LIBS}"
> + 			else
> + 				LIBS="-liconv ${LIBS}"
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
Paul Fertser Jan. 18, 2015, 3:22 p.m. UTC | #2
Hello,

Jiri Slachta <slachta@cesnet.cz> writes:
> See the statement about the transition to github:
> 	https://forum.openwrt.org/viewtopic.php?id=51078

What this doesn't explain is that it seems to me that every contributor
to the packages feed now needs to have an account on Github, needs to
use their proprietary "fork" and "pull request" methods, and that the
whole package feed maintenance now depends on a single commercial entity
and their closed-source server-side solution.

Or am I missing something here?

But if this approach is really thought-out and is likely to be helping
OpenWrt to become better, well, I guess it's all right then.
diff mbox

Patch

diff -uprN ../trunk/feeds/packages/net/dansguardian/Makefile ./feeds/packages/net/dansguardian/Makefile
--- ../trunk/feeds/packages/net/dansguardian/Makefile	1970-01-01 12:00:00.000000000 +1200
+++ ./feeds/packages/net/dansguardian/Makefile	2015-01-06 15:56:14.017306000 +1300
@@ -0,0 +1,62 @@ 
+#
+# Copyright (C) 2008-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dansguardian
+PKG_VERSION:=2.12.0.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://sourceforge.net/projects/dansguardian/files/
+PKG_MD5SUM:=2a88d0392cd28eaec02b7ee727b2e253
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/uclibc++.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dansguardian
+  SECTION:=net
+  DEPENDS:=+libpthread $(CXX_DEPENDS) +zlib
+  CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
+  TITLE:=DansGuardian
+  URL:=http://dansguardian.org
+endef
+
+define Package/dansguardian/conffiles
+/etc/dansguardian/dansguardian.conf
+endef
+
+CONFIGURE_VARS += \
+	INCLUDES="" \
+	CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
+	LIBS="-lpthread" \
+
+define Build/Configure
+	$(call Build/Configure/Default,\
+		--disable-clamav \
+		--with-sysconfsubdir=dansguardian \
+		--with-proxyuser=root \
+		--with-proxygroup=root \
+		--disable-pcre \
+	)
+endef
+
+define Package/dansguardian/install
+	$(INSTALL_DIR) $(1)/usr/sbin
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dansguardian $(1)/usr/sbin/
+	$(INSTALL_DIR) $(1)/etc
+	$(CP) $(PKG_INSTALL_DIR)/etc/dansguardian $(1)/etc/
+	$(INSTALL_DIR) $(1)/usr/share/dansguardian
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/dansguardian/transparent1x1.gif $(1)/usr/share/dansguardian/
+	$(INSTALL_DIR) $(1)/usr/share/dansguardian/languages/ukenglish
+	$(CP) $(PKG_INSTALL_DIR)/usr/share/dansguardian/languages/ukenglish/* $(1)/usr/share/dansguardian/languages/ukenglish/
+endef
+
+$(eval $(call BuildPackage,dansguardian))
diff -uprN ../trunk/feeds/packages/net/dansguardian/patches/001-include_dir.patch ./feeds/packages/net/dansguardian/patches/001-include_dir.patch
--- ../trunk/feeds/packages/net/dansguardian/patches/001-include_dir.patch	1970-01-01 12:00:00.000000000 +1200
+++ ./feeds/packages/net/dansguardian/patches/001-include_dir.patch	2015-01-06 08:08:58.494773000 +1300
@@ -0,0 +1,29 @@ 
+--- a/configure
++++ b/configure
+@@ -861,7 +861,7 @@ sysconfdir='${prefix}/etc'
+ sharedstatedir='${prefix}/com'
+ localstatedir='${prefix}/var'
+ includedir='${prefix}/include'
+-oldincludedir='/usr/include'
++oldincludedir='${prefix}/usr/include'
+ docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
+ infodir='${datarootdir}/info'
+ htmldir='${docdir}'
+@@ -6317,7 +6317,7 @@ $as_echo_n "checking for zlib... " >&6; 
+ # Check whether --with-zlib was given.
+ if test "${with_zlib+set}" = set; then
+   withval=$with_zlib;  # check for header & func (in library) in given prefix
+-	CPPFLAGS="${CPPFLAGS} -I${withval}/include"
++	CPPFLAGS="${CPPFLAGS}"
+ 	if test "x$staticzlib" = "xtrue"; then
+ 		LIBS="-Bstatic -L${withval} -lz -Bdynamic ${LIBS}"
+ 	else
+@@ -10042,7 +10042,7 @@ _ACEOF
+ if test "${with_libiconv+set}" = set; then
+   withval=$with_libiconv;  # check for header & func (in library) in given prefix
+ 			if test "x$withval" != "x"; then
+-				CPPFLAGS="${CPPFLAGS} -I${withval}/include"
++				CPPFLAGS="${CPPFLAGS}"
+ 				LIBS="-L${withval}/lib -liconv ${LIBS}"
+ 			else
+ 				LIBS="-liconv ${LIBS}"