diff mbox series

[OpenWrt-Devel] kernel: Fix rtc-ds1307 dependency on hwmon-core for 4.19

Message ID 1545090254-10959-1-git-send-email-ynezz@true.cz
State Superseded
Headers show
Series [OpenWrt-Devel] kernel: Fix rtc-ds1307 dependency on hwmon-core for 4.19 | expand

Commit Message

Petr Štetiar Dec. 17, 2018, 11:44 p.m. UTC
It seems, that since Linux 4.18-rc1 rtc-ds1307 depends on hwmon-core.

 commit 6b583a64fd1e019fd01626b46892ebf2361951c5
 Author: Heiner Kallweit <hkallweit1@gmail.com>
 Date:   Wed Sep 27 22:41:26 2017 +0200

    rtc: ds1307: simplify hwmon config

    We don't have to define an extra config symbol, IS_REACHABLE does
    what we need. And having this config symbol just to save the few
    bytes of hwmon support on non-DS3231 chips isn't worth it IMO
    (especially as the symbol is set per default).

Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 package/kernel/linux/modules/other.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Bjørn Mork Dec. 18, 2018, 8:54 a.m. UTC | #1
Petr Štetiar <ynezz@true.cz> writes:

> It seems, that since Linux 4.18-rc1 rtc-ds1307 depends on hwmon-core.
>
>  commit 6b583a64fd1e019fd01626b46892ebf2361951c5
>  Author: Heiner Kallweit <hkallweit1@gmail.com>
>  Date:   Wed Sep 27 22:41:26 2017 +0200
>
>     rtc: ds1307: simplify hwmon config
>
>     We don't have to define an extra config symbol, IS_REACHABLE does
>     what we need. And having this config symbol just to save the few
>     bytes of hwmon support on non-DS3231 chips isn't worth it IMO
>     (especially as the symbol is set per default).
>
> Signed-off-by: Petr Štetiar <ynezz@true.cz>
> ---
>  package/kernel/linux/modules/other.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index c521405..c9f4c33 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -476,7 +476,7 @@ define KernelPackage/rtc-ds1307
>    SUBMENU:=$(OTHER_MENU)
>    TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
>    DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
> -  DEPENDS:=+kmod-i2c-core +LINUX_4_14:kmod-regmap
> +  DEPENDS:=+kmod-i2c-core +LINUX_4_14:kmod-regmap +LINUX_4_19:kmod-hwmon-core
>    KCONFIG:=CONFIG_RTC_DRV_DS1307 \
>  	CONFIG_RTC_CLASS=y
>    FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko


Ah, right.  You got it.  I should leanr to read the whole thread before
replying...


Bjørn
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index c521405..c9f4c33 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -476,7 +476,7 @@  define KernelPackage/rtc-ds1307
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
   DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
-  DEPENDS:=+kmod-i2c-core +LINUX_4_14:kmod-regmap
+  DEPENDS:=+kmod-i2c-core +LINUX_4_14:kmod-regmap +LINUX_4_19:kmod-hwmon-core
   KCONFIG:=CONFIG_RTC_DRV_DS1307 \
 	CONFIG_RTC_CLASS=y
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko