diff mbox

[OpenWrt-Devel,12/13] lantiq: Add an 'All Profiles' profile

Message ID 1453183670-67000-13-git-send-email-openwrt@daniel.thecshore.com
State Changes Requested
Headers show

Commit Message

Daniel Dickinson Jan. 19, 2016, 6:07 a.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

Lantiq has enough images to make it useful to get all profiles
and multi-profile select working properly, so this patch adds
an 'All Profiles' profile, however it is only used to allow
KConfig to select all profiles and is not used standalone to
build all targets, due to the differences in devices that would
result in every image having a number of packages selected
by other profiles but not applicable the current image.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 target/linux/lantiq/image/Makefile                |  8 ++++----
 target/linux/lantiq/xrx200/profiles/00-default.mk | 17 +++++++++++++++++
 target/linux/lantiq/xrx200/profiles/01-all.mk     | 18 ++++++++++++++++++
 target/linux/lantiq/xway/profiles/00-default.mk   | 17 +++++++++++++++++
 target/linux/lantiq/xway/profiles/01-all.mk       | 18 ++++++++++++++++++
 5 files changed, 74 insertions(+), 4 deletions(-)
 create mode 100644 target/linux/lantiq/xrx200/profiles/00-default.mk
 create mode 100644 target/linux/lantiq/xrx200/profiles/01-all.mk
 create mode 100644 target/linux/lantiq/xway/profiles/00-default.mk
 create mode 100644 target/linux/lantiq/xway/profiles/01-all.mk
diff mbox

Patch

diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index d60af3c..431f206 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -426,21 +426,21 @@  Image/BuildKernel/Profile/VGV7519BRN=$(call Image/BuildKernel/Template,VGV7519BR
 Image/Build/Profile/VGV7519BRN=$(call Image/Build/$(1),$(1),VGV7519BRN,5D00008000,0x12345678,0x2083b8ed,$(1))
 
 define Image/Prepare
-	$(call Image/Prepare/Profile,$(2),,$(2))
+	$(if $(filter-out All,$(2)),$(call Image/Prepare/Profile,$(2),,$(2)))
 endef
 
 endif
 
 define Image/BuildKernel
-	$(call Image/BuildKernel/Profile/$(2),,$(2))
+	$(if $(filter-out All,$(2)),$(call Image/BuildKernel/Profile/$(2),,$(2)))
 endef
 
 define Image/InstallKernel
-	$(call Image/InstallKernel/Template/$(2))
+	$(if $(filter-out All,$(2)),$(call Image/InstallKernel/Template/$(2)))
 endef
 
 define Image/Build
-	$(call Image/Build/Profile/$(2),$(1),$(2))
+	$(if $(filter-out All,$(2)),$(call Image/Build/Profile/$(2),$(1),$(2)))
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/lantiq/xrx200/profiles/00-default.mk b/target/linux/lantiq/xrx200/profiles/00-default.mk
new file mode 100644
index 0000000..fc35e6d
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/00-default.mk
@@ -0,0 +1,17 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default package set
+  PROFILE_SKIP_DEFAULT:=1
+endef
+
+define Profile/Default/Description
+	Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/lantiq/xrx200/profiles/01-all.mk b/target/linux/lantiq/xrx200/profiles/01-all.mk
new file mode 100644
index 0000000..0c750e2
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/01-all.mk
@@ -0,0 +1,18 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/All
+  NAME:=All Profiles
+  PROFILE_SKIP_SINGLE:=1
+endef
+
+define Profile/All/Description
+	Build images for all profiles
+endef
+
+$(eval $(call Profile,All))
+
diff --git a/target/linux/lantiq/xway/profiles/00-default.mk b/target/linux/lantiq/xway/profiles/00-default.mk
new file mode 100644
index 0000000..fc35e6d
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/00-default.mk
@@ -0,0 +1,17 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default package set
+  PROFILE_SKIP_DEFAULT:=1
+endef
+
+define Profile/Default/Description
+	Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/lantiq/xway/profiles/01-all.mk b/target/linux/lantiq/xway/profiles/01-all.mk
new file mode 100644
index 0000000..0c750e2
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/01-all.mk
@@ -0,0 +1,18 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/All
+  NAME:=All Profiles
+  PROFILE_SKIP_SINGLE:=1
+endef
+
+define Profile/All/Description
+	Build images for all profiles
+endef
+
+$(eval $(call Profile,All))
+