diff mbox

[OpenWrt-Devel,09/13] sunxi: Add an 'All Profiles' profile

Message ID 1453171813-36623-10-git-send-email-openwrt@daniel.thecshore.com
State Superseded
Headers show

Commit Message

Daniel Dickinson Jan. 19, 2016, 2:50 a.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

Sunxi has enough images to make it useful to get all profiles
and multi-profile select working properly, so this patch adds
an 'All Profiles' profile, however it is only used to allow
KConfig to select all profiles and is not used standalone to
build all targets, due to the differences in devices that would
result in every image having a number of packages selected
by other profiles but not applicable the current image.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 target/linux/sunxi/image/Makefile         |  8 +++++---
 target/linux/sunxi/profiles/00-default.mk | 17 +++++++++++++++++
 target/linux/sunxi/profiles/01-all.mk     | 18 ++++++++++++++++++
 target/linux/sunxi/profiles/01-default.mk | 17 -----------------
 4 files changed, 40 insertions(+), 20 deletions(-)
 create mode 100644 target/linux/sunxi/profiles/00-default.mk
 create mode 100644 target/linux/sunxi/profiles/01-all.mk
 delete mode 100644 target/linux/sunxi/profiles/01-default.mk
diff mbox

Patch

diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 6758ba1..a17e1a2 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -106,13 +106,15 @@  endef
 define Image/Build/Profile/Linksprite_pcDuino3
 	$(call Image/Build/SDCard,$(1),sun7i-a20-pcduino3,$(2))
 endef
-endef
 
-define Image/Build
+define Image/Build/Default
 	$(call Image/Build/$(1),$(1),$(2))
 	$(call Image/Build/Profile/$(2),$(1),$(2))
-
 	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
 
+define Image/Build
+	$(if $(filter-out All,$(2))$(call Image/Build/Default,$(1),$(2)))
+endef
+
 $(eval $(call BuildImage))
diff --git a/target/linux/sunxi/profiles/00-default.mk b/target/linux/sunxi/profiles/00-default.mk
new file mode 100644
index 0000000..fc35e6d
--- /dev/null
+++ b/target/linux/sunxi/profiles/00-default.mk
@@ -0,0 +1,17 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default package set
+  PROFILE_SKIP_DEFAULT:=1
+endef
+
+define Profile/Default/Description
+	Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/sunxi/profiles/01-all.mk b/target/linux/sunxi/profiles/01-all.mk
new file mode 100644
index 0000000..0c750e2
--- /dev/null
+++ b/target/linux/sunxi/profiles/01-all.mk
@@ -0,0 +1,18 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/All
+  NAME:=All Profiles
+  PROFILE_SKIP_SINGLE:=1
+endef
+
+define Profile/All/Description
+	Build images for all profiles
+endef
+
+$(eval $(call Profile,All))
+
diff --git a/target/linux/sunxi/profiles/01-default.mk b/target/linux/sunxi/profiles/01-default.mk
deleted file mode 100644
index 7d83440..0000000
--- a/target/linux/sunxi/profiles/01-default.mk
+++ /dev/null
@@ -1,17 +0,0 @@ 
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-  NAME:=Default package set
-  PACKAGES += uboot-sunxi-A13-OLinuXino
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
-