diff mbox

[OpenWrt-Devel,v1] kernel: make kmod-thermal dependency conditional to match upstream kernel module configuration dependency for hwmon-pwmfan

Message ID 1450870482-6166-1-git-send-email-nitroshift@yahoo.com
State Accepted
Headers show

Commit Message

Sebastian Careba Dec. 23, 2015, 11:34 a.m. UTC
Signed-off-by: Sebastian Careba <nitroshift@yahoo.com>
---
 package/kernel/linux/modules/hwmon.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index ca0ff66..26bfc00 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -289,7 +289,7 @@  define KernelPackage/hwmon-pwmfan
   KCONFIG:=CONFIG_SENSORS_PWM_FAN
   FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
-  $(call AddDepends/hwmon,)
+  $(call AddDepends/hwmon, +PACKAGE_kmod-thermal:kmod-thermal)
 endef
 
 define KernelPackage/hwmon-pwmfan/description