diff mbox

[OpenWrt-Devel,1/1] TL-WR710N-v2.1

Message ID 1448190110-31257-1-git-send-email-nw@wegener-net.de
State Changes Requested
Headers show

Commit Message

Norbert Wegener Nov. 22, 2015, 11:01 a.m. UTC
# now with a git send-email working...

# This patch just extends target/linux/ar71xx/image/Makefile to build
# images also for version 2.1 of TL-WR710N

# Signed off by: Norbert Wegener <nw@wegener-net.de>
---
 target/linux/ar71xx/image/Makefile | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

John Crispin Nov. 24, 2015, 6:21 p.m. UTC | #1
Hi

On 22/11/2015 12:01, Norbert Wegener wrote:
> # now with a git send-email working...
> 

:) it looks good, however it does not apply to current trunk. did you
make sure to base this patch on latest HEAD ?

	John

> # This patch just extends target/linux/ar71xx/image/Makefile to build
> # images also for version 2.1 of TL-WR710N
> 
> # Signed off by: Norbert Wegener <nw@wegener-net.de>
> ---
>  target/linux/ar71xx/image/Makefile | 11 ++++++++++-
>  1 file changed, 10 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
> index 013a215..da2e7d4 100644
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -476,6 +476,15 @@ define Device/tl-wr710n-v2
>      CONSOLE := ttyATH0,115200
>  endef
>  
> +define Device/tl-wr710n-v2.1
> +    $(Device/tplink-8mlzma)
> +    BOARDNAME := TL-WR710N
> +    DEVICE_PROFILE := TLWR710
> +    TPLINK_HWID := 0x07100002
> +    TPLINK_HWREV := 0x00000002
> +    CONSOLE := ttyATH0,115200
> +endef
> +
>  define Device/tl-wr720n-v3
>      $(Device/tplink-4mlzma)
>      BOARDNAME := TL-WR720N-v3
> @@ -491,7 +500,7 @@ define Device/tl-wr720n-v4
>      TPLINK_HWID := 0x07200104
>      CONSOLE := ttyATH0,115200
>  endef
> -TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
> +TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr710n-v2.1 tl-wr720n-v3 tl-wr720n-v4
>  
>  define Device/tl-wr740n-v4
>      $(Device/tplink-4mlzma)
>
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 013a215..da2e7d4 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -476,6 +476,15 @@  define Device/tl-wr710n-v2
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr710n-v2.1
+    $(Device/tplink-8mlzma)
+    BOARDNAME := TL-WR710N
+    DEVICE_PROFILE := TLWR710
+    TPLINK_HWID := 0x07100002
+    TPLINK_HWREV := 0x00000002
+    CONSOLE := ttyATH0,115200
+endef
+
 define Device/tl-wr720n-v3
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WR720N-v3
@@ -491,7 +500,7 @@  define Device/tl-wr720n-v4
     TPLINK_HWID := 0x07200104
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
+TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr710n-v2.1 tl-wr720n-v3 tl-wr720n-v4
 
 define Device/tl-wr740n-v4
     $(Device/tplink-4mlzma)