diff mbox

[OpenWrt-Devel] toolchain/gdb: update to 7.10, sync with target package version

Message ID 1446658908-28891-1-git-send-email-hannu.nyman@iki.fi
State Accepted
Headers show

Commit Message

Hannu Nyman Nov. 4, 2015, 5:41 p.m. UTC
Update toolchain gdb to 7.10.
Refresh patches.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
---
 toolchain/gdb/Makefile                                    | 6 +++---
 toolchain/gdb/patches/100-no_extern_inline.patch          | 4 ++--
 toolchain/gdb/patches/110-no_testsuite.patch              | 4 ++--
 toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch | 2 +-
 4 files changed, 8 insertions(+), 8 deletions(-)
diff mbox

Patch

diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index fa5179a..f3bca77 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -1,5 +1,5 @@ 
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.8
+PKG_VERSION:=7.10
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
+PKG_MD5SUM:=2a35bac41fa8e10bf04f3a0dd7f7f363
 
 HOST_BUILD_PARALLEL:=1
 
diff --git a/toolchain/gdb/patches/100-no_extern_inline.patch b/toolchain/gdb/patches/100-no_extern_inline.patch
index bbae1d7..8c18c6e 100644
--- a/toolchain/gdb/patches/100-no_extern_inline.patch
+++ b/toolchain/gdb/patches/100-no_extern_inline.patch
@@ -21,11 +21,11 @@ 
 +#endif /* DEFINE_NON_INLINE_P */
 --- a/sim/common/sim-arange.h
 +++ b/sim/common/sim-arange.h
-@@ -62,7 +62,7 @@ extern void sim_addr_range_delete (ADDR_
+@@ -73,7 +73,7 @@ extern void sim_addr_range_delete (ADDR_
  
  /* Return non-zero if ADDR is in range AR, traversing the entire tree.
     If no range is specified, that is defined to mean "everything".  */
--extern INLINE int
+-SIM_ARANGE_INLINE int
 +extern int
  sim_addr_range_hit_p (ADDR_RANGE * /*ar*/, address_word /*addr*/);
  #define ADDR_RANGE_HIT_P(ar, addr) \
diff --git a/toolchain/gdb/patches/110-no_testsuite.patch b/toolchain/gdb/patches/110-no_testsuite.patch
index 5c5d15c..1b284ea 100644
--- a/toolchain/gdb/patches/110-no_testsuite.patch
+++ b/toolchain/gdb/patches/110-no_testsuite.patch
@@ -1,6 +1,6 @@ 
 --- a/gdb/configure
 +++ b/gdb/configure
-@@ -855,8 +855,7 @@ MAKEINFOFLAGS
+@@ -870,8 +870,7 @@ MAKEINFOFLAGS
  YACC
  YFLAGS
  XMKMF'
@@ -10,7 +10,7 @@ 
  multi-ice
  gdbserver'
  
-@@ -5168,7 +5167,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+@@ -5610,7 +5610,7 @@ $as_echo "$with_auto_load_safe_path" >&6
  
  
  
diff --git a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
index ce34c95..c8b41f2 100644
--- a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@ 
 --- a/gdb/gdbserver/configure
 +++ b/gdb/gdbserver/configure
-@@ -2183,7 +2183,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+@@ -2468,7 +2468,7 @@ $as_echo "$as_me: error: \`$ac_var' was
        ac_cache_corrupted=: ;;
      ,);;
      *)