diff mbox

[OpenWrt-Devel] iproute2: fix compile with uClibc-ng

Message ID 1446151872-17625-1-git-send-email-stijn@linux-ipv6.be
State Accepted
Headers show

Commit Message

Stijn Tintel Oct. 29, 2015, 8:51 p.m. UTC
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
---
 package/network/utils/iproute2/Makefile | 3 +++
 1 file changed, 3 insertions(+)
diff mbox

Patch

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 23834df..f5b5f4e 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -84,6 +84,9 @@  endif
 ifdef CONFIG_USE_MUSL
   TARGET_CFLAGS += -DHAVE_SETNS
 endif
+ifdef CONFIG_UCLIBC_USE_VERSION_NG
+  TARGET_CFLAGS += -DHAVE_SETNS
+endif
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections