diff mbox

[OpenWrt-Devel,4/5] malta: convert to router type target.

Message ID 1446036929-19163-5-git-send-email-yszhou4tech@gmail.com
State Superseded
Headers show

Commit Message

Yousong Zhou Oct. 28, 2015, 12:55 p.m. UTC
There is currently no relevant definition for developerboard device type
in include/target.mk, thus packages like iptables, firewall, dnsmasq
etc. are missing in the default images, rendering it almost useless
for regular testing or normal use.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
 target/linux/malta/Makefile |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Florian Fainelli Oct. 28, 2015, 4:20 p.m. UTC | #1
On Oct 28, 2015 5:56 AM, "Yousong Zhou" <yszhou4tech@gmail.com> wrote:
>
> There is currently no relevant definition for developerboard device type
> in include/target.mk, thus packages like iptables, firewall, dnsmasq
> etc. are missing in the default images, rendering it almost useless
> for regular testing or normal use.

This is by design as well here, Malta being used mostly for kernel,
toolchain and user space development, but not being an ideal router
platform.

AFAIR, the default device type is already router, so you could just
eliminate that.

>
> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
> ---
>  target/linux/malta/Makefile |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
> index c9f1586..0cce15e 100644
> --- a/target/linux/malta/Makefile
> +++ b/target/linux/malta/Makefile
> @@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
>
>  KERNEL_PATCHVER:=3.18
>
> -DEVICE_TYPE:=developerboard
> +DEVICE_TYPE:=router
>
>  include $(INCLUDE_DIR)/target.mk
>
> --
> 1.7.10.4
Yousong Zhou Oct. 29, 2015, 2:09 a.m. UTC | #2
On 29 October 2015 at 00:20, Florian Fainelli <florian@openwrt.org> wrote:
> On Oct 28, 2015 5:56 AM, "Yousong Zhou" <yszhou4tech@gmail.com> wrote:
>>
>> There is currently no relevant definition for developerboard device type
>> in include/target.mk, thus packages like iptables, firewall, dnsmasq
>> etc. are missing in the default images, rendering it almost useless
>> for regular testing or normal use.
>
> This is by design as well here, Malta being used mostly for kernel,
> toolchain and user space development, but not being an ideal router
> platform.
>
> AFAIR, the default device type is already router, so you could just
> eliminate that.
>

Okay, will do that.

                yousong

>>
>> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
>> ---
>>  target/linux/malta/Makefile |    2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
>> index c9f1586..0cce15e 100644
>> --- a/target/linux/malta/Makefile
>> +++ b/target/linux/malta/Makefile
>> @@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
>>
>>  KERNEL_PATCHVER:=3.18
>>
>> -DEVICE_TYPE:=developerboard
>> +DEVICE_TYPE:=router
>>
>>  include $(INCLUDE_DIR)/target.mk
>>
>> --
>> 1.7.10.4
diff mbox

Patch

diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index c9f1586..0cce15e 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -15,7 +15,7 @@  MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
 
-DEVICE_TYPE:=developerboard
+DEVICE_TYPE:=router
 
 include $(INCLUDE_DIR)/target.mk