diff mbox

[OpenWrt-Devel,v2,2/4] kernel: add ath3k module package

Message ID 1444687682-23204-3-git-send-email-psidhu@gateworks.com
State Accepted
Headers show

Commit Message

Pushpal Sidhu Oct. 12, 2015, 10:08 p.m. UTC
Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
---
Changes in v2:
 * ath3k now depends on ar3k-firmware

 package/kernel/linux/modules/other.mk | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d438fbe..9ff291d 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -78,6 +78,25 @@  endef
 
 $(eval $(call KernelPackage,bluetooth))
 
+define KernelPackage/ath3k
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=ATH3K Kernel Module support
+  DEPENDS:=+kmod-bluetooth +ar3k-firmware
+  KCONFIG:= \
+	CONFIG_BT_ATH3K \
+	CONFIG_BT_HCIUART_ATH3K
+  $(call AddDepends/bluetooth)
+  FILES:= \
+	$(LINUX_DIR)/drivers/bluetooth/ath3k.ko
+  AUTOLOAD:=$(call AutoProbe,ath3k)
+endef
+
+define KernelPackage/ath3k/description
+ Kernel support for ATH3K Module
+endef
+
+$(eval $(call KernelPackage,ath3k))
+
 
 define KernelPackage/bluetooth_6lowpan
   SUBMENU:=$(OTHER_MENU)