diff mbox

[OpenWrt-Devel] ar71xx: rename firmware for Chinese version of TL-WR941ND v6

Message ID 1443344869-6165-1-git-send-email-zajec5@gmail.com
State Accepted
Delegated to: Rafał Miłecki
Headers show

Commit Message

Rafał Miłecki Sept. 27, 2015, 9:07 a.m. UTC
It seems there are two *different* versions on TL-WR941ND v6: Chinese
and European one. Currently supported in OpenWrt is Chinese one. Rename
firmware to make it clear.
For details see:
http://wiki.openwrt.org/toh/tp-link/tl-wr941nd
https://forum.openwrt.org/viewtopic.php?id=59295

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
---
 target/linux/ar71xx/image/Makefile | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Matthias Schiffer Sept. 27, 2015, 10:50 a.m. UTC | #1
Thanks, I've been meaning to send the same patch next week. With r46948,
the international version can now be supported as well, I'll send an
updated version of http://patchwork.ozlabs.org/patch/504451/ shortly.


On 09/27/2015 06:07 PM, Rafał Miłecki wrote:
> It seems there are two *different* versions on TL-WR941ND v6: Chinese
> and European one. Currently supported in OpenWrt is Chinese one. Rename
> firmware to make it clear.
> For details see:
> http://wiki.openwrt.org/toh/tp-link/tl-wr941nd
> https://forum.openwrt.org/viewtopic.php?id=59295
> 
> Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
> ---
>  target/linux/ar71xx/image/Makefile | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
> index ca63129..b5fc396 100644
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -677,13 +677,14 @@ define Device/tl-wr941nd-v5
>      TPLINK_HWID := 0x09410005
>  endef
>  
> -define Device/tl-wr941nd-v6
> +# Chinese version (unline European) is similar to the TL-WDR3500
> +define Device/tl-wr941nd-v6-cn
>      $(Device/tplink-4mlzma)
>      BOARDNAME := TL-WDR3500
>      DEVICE_PROFILE := TLWR941
>      TPLINK_HWID := 0x09410006
>  endef
> -TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6
> +TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6-cn
>  
>  define Device/tl-wr1041n-v2
>      $(Device/tplink-4mlzma)
>
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ca63129..b5fc396 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -677,13 +677,14 @@  define Device/tl-wr941nd-v5
     TPLINK_HWID := 0x09410005
 endef
 
-define Device/tl-wr941nd-v6
+# Chinese version (unline European) is similar to the TL-WDR3500
+define Device/tl-wr941nd-v6-cn
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WDR3500
     DEVICE_PROFILE := TLWR941
     TPLINK_HWID := 0x09410006
 endef
-TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6
+TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6-cn
 
 define Device/tl-wr1041n-v2
     $(Device/tplink-4mlzma)