diff mbox

[OpenWrt-Devel] kernel: bluetooth: Add dependency to kmod-crypto-ecb

Message ID 1432908927-10290-1-git-send-email-br1@einfach.org
State Accepted
Headers show

Commit Message

Bruno Randolf May 29, 2015, 2:15 p.m. UTC
Add dependency of kmod-crypto-ecb to kmod-bluetooth to avoid the kernel warning
"Bluetooth: Unable to create crypto context".

Signed-off-by: Bruno Randolf <br1@einfach.org>
---
 package/kernel/linux/modules/other.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 082c74a..955c140 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -28,7 +28,7 @@  $(eval $(call KernelPackage,6lowpan))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-lib-crc16 +kmod-hid
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid
   KCONFIG:= \
 	CONFIG_BLUEZ \
 	CONFIG_BLUEZ_L2CAP \