diff mbox

[OpenWrt-Devel,5/5] kernel: upgrade 4.0 to rc6

Message ID 1427759279-2303-5-git-send-email-mathieu@codeaurora.org
State Superseded
Headers show

Commit Message

Mathieu Olivari March 30, 2015, 11:47 p.m. UTC
Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
---
 include/kernel-version.mk                          |  4 +--
 .../patches-4.0/668-fix-ipv6-throw-routes.patch    | 31 ----------------------
 2 files changed, 2 insertions(+), 33 deletions(-)
 delete mode 100644 target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch
diff mbox

Patch

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 16f76e7..977c8a0 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,14 +7,14 @@  LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .35
 LINUX_VERSION-3.18 = .9
-LINUX_VERSION-4.0 = -rc5
+LINUX_VERSION-4.0 = -rc6
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.35 = e5e92c40d14bc8ae9a8701db4e1cbb27
 LINUX_KERNEL_MD5SUM-3.18.9  = 44cd16ada5eb03589f696f083cd2323b
-LINUX_KERNEL_MD5SUM-4.0-rc5 = b26150c980099ef554b26d07f470e647
+LINUX_KERNEL_MD5SUM-4.0-rc6 = bec0aeeacab2852d9a17ccbfa7e280f8
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch b/target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch
deleted file mode 100644
index 283ffce..0000000
--- a/target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch
+++ /dev/null
@@ -1,31 +0,0 @@ 
-From 9cd600244515bd4540898411ab781a97f0cc387f Mon Sep 17 00:00:00 2001
-From: Steven Barth <steven@midlink.org>
-Date: Thu, 19 Mar 2015 11:54:50 +0100
-Subject: [PATCH] ipv6: fix backtracking for throw routes
-
-for throw routes to trigger evaluation of other policy rules
-EAGAIN needs to be propagated up to fib_rules_lookup
-similar to how its done for IPv4
-
-A simple testcase for verification is:
-
-ip -6 rule add lookup 33333 priority 33333
-ip -6 route add throw 2001:db8::1
-ip -6 route add 2001:db8::1 via fe80::1 dev wlan0 table 33333
-ip route get 2001:db8::1
-
-Signed-off-by: Steven Barth <cyrus@openwrt.org>
----
- net/ipv6/fib6_rules.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/net/ipv6/fib6_rules.c
-+++ b/net/ipv6/fib6_rules.c
-@@ -104,6 +104,7 @@ static int fib6_rule_action(struct fib_r
- 				goto again;
- 			flp6->saddr = saddr;
- 		}
-+		err = rt->dst.error;
- 		goto out;
- 	}
- again: