diff mbox

[OpenWrt-Devel,RFC] brcm47xx: image: use standard KERNEL_IMAGE to avoid warnings

Message ID 1427695943-13815-1-git-send-email-zajec5@gmail.com
State Accepted
Delegated to: Rafał Miłecki
Headers show

Commit Message

Rafał Miłecki March 30, 2015, 6:12 a.m. UTC
KERNEL_IMAGE is used as target rule so reusing the same name causes:
Makefile:326: warning: overriding recipe for target `bin/brcm47xx/vmlinux.lzma'
Makefile:326: warning: ignoring old recipe for target `bin/brcm47xx/vmlinux.lzma'
Makefile:326: warning: overriding recipe for target `build_dir/target-mipsel_74kc+dsp2_uClibc-0.9.33.2/linux-brcm47xx_mips74k/vmlinux.lzma'
Makefile:326: warning: ignoring old recipe for target `build_dir/target-mipsel_74kc+dsp2_uClibc-0.9.33.2/linux-brcm47xx_mips74k/vmlinux.lzma'

Unfortunately this will cause copying vmlinux.lzma over and over like:
cp vmlinux.lzma FOO-kernel.bin
which is redundant on brcm47xx where we never modify kernel image.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
---
With this fix using new image building system adds another overhead
because 99% of devices should share both: kernel (vmlinux.lzma) and TRX.

I'm wondering if using new image building system in its current form
makes any sense for this simple MIPS target. The gain from building
images in parellel may be lost due to re-generating simple files.
---
 target/linux/brcm47xx/image/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 5410ed3..b46ab7b 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -138,8 +138,9 @@  DEVICE_VARS += DEVICE_ID VERSION
 DEVICE_VARS += BOARD_ID REGION
 
 define Device/Default
+	KERNEL := kernel-bin
 	IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
-	KERNEL_IMAGE = vmlinux.lzma
+	KERNEL_NAME = vmlinux.lzma
 	FILESYSTEMS := $(FS_64K)
 	IMAGES := trx
 	IMAGE/trx := trx-with-loader