diff mbox

[OpenWrt-Devel,2/3] kernel: remove mp-alg

Message ID 1427570110-31355-2-git-send-email-dirkneukirchen@web.de
State Accepted
Headers show

Commit Message

Dirk Neukirchen March 28, 2015, 7:15 p.m. UTC
from upstream
commit title: "[IPV4]: The scheduled removal of multipath cached routing support."
removed in Kernel 2.6.23 (2007)
Reasons: very buggy, no maintainer, no fixes

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/netsupport.mk | 27 ---------------------------
 1 file changed, 27 deletions(-)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 9de1ce2..4ac23c6 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -843,33 +843,6 @@  endef
 $(eval $(call KernelPackage,ax25))
 
 
-define KernelPackage/mp-alg
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=ECMP caching algorithms
-  KCONFIG:= \
-	CONFIG_IP_ROUTE_MULTIPATH_RR \
-	CONFIG_IP_ROUTE_MULTIPATH_RANDOM \
-	CONFIG_IP_ROUTE_MULTIPATH_WRANDOM \
-	CONFIG_IP_ROUTE_MULTIPATH_DRR
-  FILES:= \
-	$(LINUX_DIR)/net/ipv4/multipath_rr.ko \
-	$(LINUX_DIR)/net/ipv4/multipath_random.ko \
-	$(LINUX_DIR)/net/ipv4/multipath_wrandom.ko \
-	$(LINUX_DIR)/net/ipv4/multipath_drr.ko
-  AUTOLOAD:=$(call AutoLoad,35,multipath_rr multipath_random multipath_wrandom multipath_drr)
-endef
-
-define KernelPackage/mp-alg/description
- Kernel modules that provide several different algorithms for multipath
- route selection from the route cache. The iproute "mpath" argument allows
- specifying which algorithm to use for routes.
- quagga (at least <=0.99.6) requires a multipath patch to support this
- cached mp route feature.
-endef
-
-$(eval $(call KernelPackage,mp-alg))
-
-
 define KernelPackage/pktgen
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   DEPENDS:=@!TARGET_uml