diff mbox

[OpenWrt-Devel] lldpd: make LLDP-MED, DOT1 and DOT3 extensions disable-able

Message ID 1426166651-27698-1-git-send-email-ardeleanalex@gmail.com
State Accepted
Headers show

Commit Message

Alexandru Ardelean March 12, 2015, 1:24 p.m. UTC
The names for the config options were taken from lldpd's
configure.ac file.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 package/network/services/lldpd/Config.in | 16 ++++++++++++++++
 package/network/services/lldpd/Makefile  |  3 +++
 2 files changed, 19 insertions(+)
diff mbox

Patch

diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
index c7d4795..a416490 100644
--- a/package/network/services/lldpd/Config.in
+++ b/package/network/services/lldpd/Config.in
@@ -21,8 +21,24 @@  config LLDPD_WITH_SONMP
 	default y
 	prompt "Enable support for the SynOptics Network Management Protocol"
 
+config LLDPD_WITH_LLDPMED
+	bool
+	prompt "Enable LLDP-MED extension"
+	default y
+
+config LLDPD_WITH_DOT1
+	bool
+	prompt "Enable Dot1 extension (VLAN stuff)"
+	default y
+
+config LLDPD_WITH_DOT3
+	bool
+	prompt "Enable Dot3 extension (PHY stuff)"
+	default y
+
 config LLDPD_WITH_JSON
 	bool
 	prompt "Enable JSON output for the LLDP Command-Line Interface"
 	default n
+
 endmenu
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 5a1921e..6f97f45 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -85,6 +85,9 @@  CONFIGURE_ARGS += \
 	$(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
 	$(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
 	$(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+	$(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
+	$(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
+	$(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
 	$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
 	$(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)