diff mbox

[OpenWrt-Devel,v2,6/8] mvebu: Fix NAND and NOR options

Message ID 1423060626-17088-7-git-send-email-maxime.ripard@free-electrons.com
State Not Applicable
Headers show

Commit Message

Maxime Ripard Feb. 4, 2015, 2:37 p.m. UTC
All the boards but Mamba had wrong UBI options so far, making it impossible to
flash the built image on their respective storage medium.

Fix all of the supported boards in order to make the generated images useful.

Tested on a Mirabox, an Armada XP GP and an Openblocks AX3, and used the NAND
chip datasheet for the others.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
---
 target/linux/mvebu/image/Makefile | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)
diff mbox

Patch

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index a8fc4de134f8..c8ec72e87ce3 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -125,14 +125,18 @@  define MultiProfile
   endef
 endef
 
+# Boards with NAND, without subpages
+$(eval $(call NANDProfile,370-DB,armada-370-db,512KiB,4096))
+$(eval $(call NANDProfile,370-RD,armada-370-rd,512KiB,4096))
+$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,512KiB,4096))
+$(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
+$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
+
 # Boards with NAND, with subpages
-$(eval $(call NANDProfile,370-DB,armada-370-db,128KiB,2048,512))
-$(eval $(call NANDProfile,370-RD,armada-370-rd,128KiB,2048,512))
 $(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
-$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,128KiB,2048,512))
-$(eval $(call NANDProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-DB,armada-xp-db,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-GP,armada-xp-gp,128KiB,2048,512))
+
+# Boards with large NOR, where we want to use UBI
+$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
 
 define Image/Build/Profile/Mamba/squashfs
 	$(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)