diff mbox

[OpenWrt-Devel,RFC,1/7] kexec-tools: add patch for fixing kexec-tools' configure.ac.

Message ID 1422021132-24526-2-git-send-email-yszhou4tech@gmail.com
State Changes Requested
Headers show

Commit Message

Yousong Zhou Jan. 23, 2015, 1:52 p.m. UTC
Add necessary quoting to fix the following error when running the
generated configure script.

	checking for lzma_code in -llzma... ./configure: line 4756: ac_fn_c_try_link: command not found

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
 .../kexec-tools/patches/101-fix-configure_ac.patch |   33 ++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 package/boot/kexec-tools/patches/101-fix-configure_ac.patch
diff mbox

Patch

diff --git a/package/boot/kexec-tools/patches/101-fix-configure_ac.patch b/package/boot/kexec-tools/patches/101-fix-configure_ac.patch
new file mode 100644
index 0000000..8b02f8d
--- /dev/null
+++ b/package/boot/kexec-tools/patches/101-fix-configure_ac.patch
@@ -0,0 +1,33 @@ 
+Index: kexec-tools-2.0.4/configure.ac
+===================================================================
+--- kexec-tools-2.0.4.orig/configure.ac	2014-08-29 17:15:17.935820544 +0800
++++ kexec-tools-2.0.4/configure.ac	2014-08-29 17:15:30.120331580 +0800
+@@ -147,22 +147,22 @@
+ dnl See if I have a usable copy of zlib available
+ if test "$with_zlib" = yes ; then
+ 	AC_CHECK_HEADER(zlib.h,
+-		AC_CHECK_LIB(z, inflateInit_, ,
+-		AC_MSG_NOTICE([zlib support disabled])))
++		[AC_CHECK_LIB(z, inflateInit_, ,
++		AC_MSG_NOTICE([zlib support disabled]))])
+ fi
+ 
+ dnl See if I have a usable copy of lzma available
+ if test "$with_lzma" = yes ; then
+ 	AC_CHECK_HEADER(lzma.h,
+-		AC_CHECK_LIB(lzma, lzma_code, ,
+-		AC_MSG_NOTICE([lzma support disabled])))
++		[AC_CHECK_LIB(lzma, lzma_code, ,
++		AC_MSG_NOTICE([lzma support disabled]))])
+ fi
+ 
+ dnl find Xen control stack libraries
+ if test "$with_xen" = yes ; then
+ 	AC_CHECK_HEADER(xenctrl.h,
+-		AC_CHECK_LIB(xenctrl, xc_version, ,
+-		AC_MSG_NOTICE([Xen support disabled])))
++		[AC_CHECK_LIB(xenctrl, xc_version, ,
++		AC_MSG_NOTICE([Xen support disabled]))])
+ 	if test "$ac_cv_lib_xenctrl_xc_version" = yes ; then
+ 		AC_CHECK_FUNCS(xc_get_machine_memory_map)
+ 	fi