diff mbox

[OpenWrt-Devel,1/5] libubox: drop legacy json-c support

Message ID 1415703092-46458-1-git-send-email-yszhou4tech@gmail.com
State Superseded
Headers show

Commit Message

Yousong Zhou Nov. 11, 2014, 10:51 a.m. UTC
The cmake logic is wrong (E.G. PKG_CHECK_FOR_MODULES fails unless all
modules are found), and the legacy libjson.so name is also used by the other
libjson (http://sourceforge.net/projects/libjson/) which provides an
incompatible API, so just drop it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
 CMakeLists.txt |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yousong Zhou Dec. 8, 2014, 3:10 a.m. UTC | #1
On 11 November 2014 at 18:51, Yousong Zhou <yszhou4tech@gmail.com> wrote:
> The cmake logic is wrong (E.G. PKG_CHECK_FOR_MODULES fails unless all
> modules are found), and the legacy libjson.so name is also used by the other
> libjson (http://sourceforge.net/projects/libjson/) which provides an
> incompatible API, so just drop it.
>
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>

This patch was take from buildroot repository [1].  The whole series
is for libubox.

[1] http://git.buildroot.net/buildroot/tree/package/libubox/libubox-01-drop-legacy-json-c.patch

                yousong

> ---
>  CMakeLists.txt |    4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/CMakeLists.txt b/CMakeLists.txt
> index f24fee9..737f2ae 100644
> --- a/CMakeLists.txt
> +++ b/CMakeLists.txt
> @@ -13,7 +13,7 @@ IF(APPLE)
>  ENDIF()
>
>  INCLUDE(FindPkgConfig)
> -PKG_CHECK_MODULES(JSONC json-c json)
> +PKG_CHECK_MODULES(JSONC json-c)
>  IF(JSONC_FOUND)
>    ADD_DEFINITIONS(-DJSONC)
>    INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})
> @@ -45,7 +45,7 @@ INSTALL(TARGETS ubox ubox-static
>
>  ADD_SUBDIRECTORY(lua)
>
> -find_library(json NAMES json-c json)
> +find_library(json NAMES json-c)
>  IF(EXISTS ${json})
>         ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
>         TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})
> --
> 1.7.10.4
>
diff mbox

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index f24fee9..737f2ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@  IF(APPLE)
 ENDIF()
 
 INCLUDE(FindPkgConfig)
-PKG_CHECK_MODULES(JSONC json-c json)
+PKG_CHECK_MODULES(JSONC json-c)
 IF(JSONC_FOUND)
   ADD_DEFINITIONS(-DJSONC)
   INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})
@@ -45,7 +45,7 @@  INSTALL(TARGETS ubox ubox-static
 
 ADD_SUBDIRECTORY(lua)
 
-find_library(json NAMES json-c json)
+find_library(json NAMES json-c)
 IF(EXISTS ${json})
 	ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
 	TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})