diff mbox series

[ovs-dev,v2] acinclude: Use standardized DPDK component defines.

Message ID 20210916061106.44853-1-sunil.pai.g@intel.com
State Accepted
Delegated to: Ilya Maximets
Headers show
Series [ovs-dev,v2] acinclude: Use standardized DPDK component defines. | expand

Checks

Context Check Description
ovsrobot/apply-robot success apply and check: success
ovsrobot/github-robot-_Build_and_Test success github build: passed

Commit Message

Pai G, Sunil Sept. 16, 2021, 6:11 a.m. UTC
The DPDK component defines have been renamed from
RTE_LIBRTE_* to macro's of the form:
"RTE_" + <class> + "_" + drivername
as documented in the commit [1].
This commit replaces the old macro's with new ones.

Macro's changed:
        OLD                   NEW
     ---------            ----------
RTE_LIBRTE_PMD_PCAP   --> RTE_NET_PCAP
RTE_LIBRTE_PMD_AF_XDP --> RTE_NET_AF_XDP
RTE_LIBRTE_MLX5_PMD   --> RTE_NET_MLX5
RTE_LIBRTE_MLX4_PMD   --> RTE_NET_MLX4

[1]: 762bfccc8abf ("config: remove compatibility build defines")

Signed-off-by: Sunil Pai G <sunil.pai.g@intel.com>

---
v1 -> v2:
* Modify commit message to include the right DPDK reference commit.
* Change target branch from dpdk-latest to master.
---
 acinclude.m4 | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

David Marchand Sept. 16, 2021, 7:39 p.m. UTC | #1
On Thu, Sep 16, 2021 at 8:11 AM Sunil Pai G <sunil.pai.g@intel.com> wrote:
>
> The DPDK component defines have been renamed from
> RTE_LIBRTE_* to macro's of the form:
> "RTE_" + <class> + "_" + drivername
> as documented in the commit [1].

Nit: for clarity, "in the DPDK commit [1]."

> This commit replaces the old macro's with new ones.

Nit: "This commit" is ambiguous when read after the first sentence.
I'd go with a simple: "Replace the old macros with new form", or "Use
the new form of macros".

>
> Macro's changed:
>         OLD                   NEW
>      ---------            ----------
> RTE_LIBRTE_PMD_PCAP   --> RTE_NET_PCAP
> RTE_LIBRTE_PMD_AF_XDP --> RTE_NET_AF_XDP
> RTE_LIBRTE_MLX5_PMD   --> RTE_NET_MLX5
> RTE_LIBRTE_MLX4_PMD   --> RTE_NET_MLX4
>
> [1]: 762bfccc8abf ("config: remove compatibility build defines")
>
> Signed-off-by: Sunil Pai G <sunil.pai.g@intel.com>

Those two nits can be fixed when applying.
Reviewed-by: David Marchand <david.marchand@redhat.com>

Thanks.
Ilya Maximets Oct. 12, 2021, 7:33 p.m. UTC | #2
On 9/16/21 21:39, David Marchand wrote:
> On Thu, Sep 16, 2021 at 8:11 AM Sunil Pai G <sunil.pai.g@intel.com> wrote:
>>
>> The DPDK component defines have been renamed from
>> RTE_LIBRTE_* to macro's of the form:
>> "RTE_" + <class> + "_" + drivername
>> as documented in the commit [1].
> 
> Nit: for clarity, "in the DPDK commit [1]."
> 
>> This commit replaces the old macro's with new ones.
> 
> Nit: "This commit" is ambiguous when read after the first sentence.
> I'd go with a simple: "Replace the old macros with new form", or "Use
> the new form of macros".
> 
>>
>> Macro's changed:
>>         OLD                   NEW
>>      ---------            ----------
>> RTE_LIBRTE_PMD_PCAP   --> RTE_NET_PCAP
>> RTE_LIBRTE_PMD_AF_XDP --> RTE_NET_AF_XDP
>> RTE_LIBRTE_MLX5_PMD   --> RTE_NET_MLX5
>> RTE_LIBRTE_MLX4_PMD   --> RTE_NET_MLX4
>>
>> [1]: 762bfccc8abf ("config: remove compatibility build defines")
>>
>> Signed-off-by: Sunil Pai G <sunil.pai.g@intel.com>
> 
> Those two nits can be fixed when applying.
> Reviewed-by: David Marchand <david.marchand@redhat.com>
> 
> Thanks.
> 
> 

Thanks!  I updated the commit message and applied.

Best regards, Ilya Maximets.
diff mbox series

Patch

diff --git a/acinclude.m4 b/acinclude.m4
index dba365ea1..8ab690f47 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -446,11 +446,11 @@  AC_DEFUN([OVS_CHECK_DPDK], [
       OVS_FIND_DEPENDENCY([get_mempolicy], [numa], [libnuma])
     ], [], [[#include <rte_config.h>]])
 
-    AC_CHECK_DECL([RTE_LIBRTE_PMD_PCAP], [
+    AC_CHECK_DECL([RTE_NET_PCAP], [
       OVS_FIND_DEPENDENCY([pcap_dump_close], [pcap], [libpcap])
     ], [], [[#include <rte_config.h>]])
 
-    AC_CHECK_DECL([RTE_LIBRTE_PMD_AF_XDP], [
+    AC_CHECK_DECL([RTE_NET_AF_XDP], [
       LIBBPF_LDADD="-lbpf"
     ], [], [[#include <rte_config.h>]])
 
@@ -458,14 +458,14 @@  AC_DEFUN([OVS_CHECK_DPDK], [
       AC_DEFINE([VHOST_NUMA], [1], [NUMA Aware vHost support detected in DPDK.])
     ], [], [[#include <rte_config.h>]])
 
-    AC_CHECK_DECL([RTE_LIBRTE_MLX5_PMD], [dnl found
+    AC_CHECK_DECL([RTE_NET_MLX5], [dnl found
       AC_CHECK_DECL([RTE_IBVERBS_LINK_DLOPEN], [], [dnl not found
         OVS_FIND_DEPENDENCY([mlx5dv_create_wq], [mlx5], [libmlx5])
         OVS_FIND_DEPENDENCY([verbs_init_cq], [ibverbs], [libibverbs])
       ], [[#include <rte_config.h>]])
     ], [], [[#include <rte_config.h>]])
 
-    AC_CHECK_DECL([RTE_LIBRTE_MLX4_PMD], [dnl found
+    AC_CHECK_DECL([RTE_NET_MLX4], [dnl found
       AC_CHECK_DECL([RTE_IBVERBS_LINK_DLOPEN], [], [dnl not found
         OVS_FIND_DEPENDENCY([mlx4dv_init_obj], [mlx4], [libmlx4])
         OVS_FIND_DEPENDENCY([verbs_init_cq], [ibverbs], [libibverbs])