diff mbox series

[ovs-dev,V3,22/24] acinclude: Enable builds up to Linux 5.8

Message ID 20200916173311.30956-23-gvrose8192@gmail.com
State Changes Requested
Headers show
Series Add support for Linux kernels up to 5.8.x | expand

Commit Message

Gregory Rose Sept. 16, 2020, 5:33 p.m. UTC
Allow building openvswitch against Linux kernels up to and including
version 5.8.

Signed-off-by: Greg Rose <gvrose8192@gmail.com>
---
 acinclude.m4 | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yi-Hung Wei Sept. 30, 2020, 10:56 p.m. UTC | #1
On Wed, Sep 16, 2020 at 10:34 AM Greg Rose <gvrose8192@gmail.com> wrote:
>
> Allow building openvswitch against Linux kernels up to and including
> version 5.8.
>
> Signed-off-by: Greg Rose <gvrose8192@gmail.com>
> ---
Acked-by: Yi-Hung Wei <yihung.wei@gmail.com>
diff mbox series

Patch

diff --git a/acinclude.m4 b/acinclude.m4
index 3d56510a0..1460289ca 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -167,10 +167,10 @@  AC_DEFUN([OVS_CHECK_LINUX], [
     AC_MSG_RESULT([$kversion])
 
     if test "$version" -ge 5; then
-       if test "$version" = 5 && test "$patchlevel" -le 5; then
+       if test "$version" = 5 && test "$patchlevel" -le 8; then
           : # Linux 5.x
        else
-          AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 5.5.x is not supported (please refer to the FAQ for advice)])
+          AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 5.8.x is not supported (please refer to the FAQ for advice)])
        fi
     elif test "$version" = 4; then
        : # Linux 4.x