diff mbox series

[ovs-dev] net: openswitch: reuse the helper variable to improve the code readablity

Message ID 1600413270-38398-1-git-send-email-prime.zeng@hisilicon.com
State Awaiting Upstream
Headers show
Series [ovs-dev] net: openswitch: reuse the helper variable to improve the code readablity | expand

Commit Message

Zengtao (B) Sept. 18, 2020, 7:14 a.m. UTC
In the function ovs_ct_limit_exit, there is already a helper vaibale
which could be reused to improve the readability, so i fix it in this
patch.

Signed-off-by: Zeng Tao <prime.zeng@hisilicon.com>
---
 net/openvswitch/conntrack.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

David Miller Sept. 18, 2020, 9:24 p.m. UTC | #1
From: Zeng Tao <prime.zeng@hisilicon.com>
Date: Fri, 18 Sep 2020 15:14:30 +0800

> In the function ovs_ct_limit_exit, there is already a helper vaibale
> which could be reused to improve the readability, so i fix it in this
> patch.
> 
> Signed-off-by: Zeng Tao <prime.zeng@hisilicon.com>

Applied, thanks.
diff mbox series

Patch

diff --git a/net/openvswitch/conntrack.c b/net/openvswitch/conntrack.c
index a3f1204..e86b960 100644
--- a/net/openvswitch/conntrack.c
+++ b/net/openvswitch/conntrack.c
@@ -1901,8 +1901,8 @@  static void ovs_ct_limit_exit(struct net *net, struct ovs_net *ovs_net)
 					 lockdep_ovsl_is_held())
 			kfree_rcu(ct_limit, rcu);
 	}
-	kfree(ovs_net->ct_limit_info->limits);
-	kfree(ovs_net->ct_limit_info);
+	kfree(info->limits);
+	kfree(info);
 }
 
 static struct sk_buff *