diff mbox series

orinoco: avoid assertion in case of NULL pointer

Message ID 20191215195900.6109-1-pakki001@umn.edu
State Awaiting Upstream
Delegated to: David Miller
Headers show
Series orinoco: avoid assertion in case of NULL pointer | expand

Commit Message

Aditya Pakki Dec. 15, 2019, 7:58 p.m. UTC
In ezusb_init, if upriv is NULL, the code crashes. However, the caller
in ezusb_probe can handle the error and print the failure message.
The patch replaces the BUG_ON call to error return.

Signed-off-by: Aditya Pakki <pakki001@umn.edu>
---
 drivers/net/wireless/intersil/orinoco/orinoco_usb.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Markus Elfring Dec. 16, 2019, 9:50 a.m. UTC | #1
> The patch replaces the BUG_ON call to error return.

Would a wording like “Replace the BUG_ON() call by a return of an error code
after a null pointer check” be nicer for this change description?

Will the tag “Fixes” become helpful here?

Regards,
Markus
Kalle Valo Dec. 18, 2019, 7:09 p.m. UTC | #2
Aditya Pakki <pakki001@umn.edu> wrote:

> In ezusb_init, if upriv is NULL, the code crashes. However, the caller
> in ezusb_probe can handle the error and print the failure message.
> The patch replaces the BUG_ON call to error return.
> 
> Signed-off-by: Aditya Pakki <pakki001@umn.edu>

Patch applied to wireless-drivers-next.git, thanks.

c705f9fc6a17 orinoco: avoid assertion in case of NULL pointer
diff mbox series

Patch

diff --git a/drivers/net/wireless/intersil/orinoco/orinoco_usb.c b/drivers/net/wireless/intersil/orinoco/orinoco_usb.c
index 40a8b941ad5c..813de06c03de 100644
--- a/drivers/net/wireless/intersil/orinoco/orinoco_usb.c
+++ b/drivers/net/wireless/intersil/orinoco/orinoco_usb.c
@@ -1361,7 +1361,8 @@  static int ezusb_init(struct hermes *hw)
 	int retval;
 
 	BUG_ON(in_interrupt());
-	BUG_ON(!upriv);
+	if (!upriv)
+		return -EINVAL;
 
 	upriv->reply_count = 0;
 	/* Write the MAGIC number on the simulated registers to keep