From patchwork Tue Aug 2 12:18:09 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Baole Ni X-Patchwork-Id: 654840 X-Patchwork-Delegate: davem@davemloft.net Return-Path: X-Original-To: patchwork-incoming@ozlabs.org Delivered-To: patchwork-incoming@ozlabs.org Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by ozlabs.org (Postfix) with ESMTP id 3s3d6M0yb0z9t3R for ; Tue, 2 Aug 2016 23:56:43 +1000 (AEST) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S967009AbcHBN4l (ORCPT ); Tue, 2 Aug 2016 09:56:41 -0400 Received: from mga02.intel.com ([134.134.136.20]:19151 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965817AbcHBM5R (ORCPT ); Tue, 2 Aug 2016 08:57:17 -0400 Received: from fmsmga002.fm.intel.com ([10.253.24.26]) by orsmga101.jf.intel.com with ESMTP; 02 Aug 2016 05:55:50 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033609010" Received: from shsibuild003.sh.intel.com ([10.239.146.225]) by fmsmga002.fm.intel.com with ESMTP; 02 Aug 2016 05:55:47 -0700 From: Baole Ni To: pablo@netfilter.org, kaber@trash.net, kadlec@blackhole.kfki.hu, davem@davemloft.net, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: netfilter-devel@vger.kernel.org, coreteam@netfilter.org, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, aryabinin@virtuozzo.com Subject: [PATCH 1119/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:18:09 +0800 Message-Id: <20160802121809.24725-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: netdev-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: netdev@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- net/netfilter/nf_conntrack_amanda.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/net/netfilter/nf_conntrack_amanda.c b/net/netfilter/nf_conntrack_amanda.c index 57a26cc..6311f98 100644 --- a/net/netfilter/nf_conntrack_amanda.c +++ b/net/netfilter/nf_conntrack_amanda.c @@ -34,9 +34,9 @@ MODULE_LICENSE("GPL"); MODULE_ALIAS("ip_conntrack_amanda"); MODULE_ALIAS_NFCT_HELPER("amanda"); -module_param(master_timeout, uint, 0600); +module_param(master_timeout, uint, S_IRUSR | S_IWUSR); MODULE_PARM_DESC(master_timeout, "timeout for the master connection"); -module_param(ts_algo, charp, 0400); +module_param(ts_algo, charp, S_IRUSR); MODULE_PARM_DESC(ts_algo, "textsearch algorithm to use (default kmp)"); unsigned int (*nf_nat_amanda_hook)(struct sk_buff *skb,