From patchwork Tue Aug 2 11:45:17 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Baole Ni X-Patchwork-Id: 654733 X-Patchwork-Delegate: davem@davemloft.net Return-Path: X-Original-To: patchwork-incoming@ozlabs.org Delivered-To: patchwork-incoming@ozlabs.org Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by ozlabs.org (Postfix) with ESMTP id 3s3b2s47zCz9t41 for ; Tue, 2 Aug 2016 22:23:33 +1000 (AEST) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S964804AbcHBMXM (ORCPT ); Tue, 2 Aug 2016 08:23:12 -0400 Received: from mga01.intel.com ([192.55.52.88]:35201 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S964792AbcHBMW7 (ORCPT ); Tue, 2 Aug 2016 08:22:59 -0400 Received: from orsmga002.jf.intel.com ([10.7.209.21]) by fmsmga101.fm.intel.com with ESMTP; 02 Aug 2016 05:22:58 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028274954" Received: from shsibuild003.sh.intel.com ([10.239.146.225]) by orsmga002.jf.intel.com with ESMTP; 02 Aug 2016 05:22:56 -0700 From: Baole Ni To: stas.yakovlev@gmail.com, kvalo@codeaurora.org, bkenward@solarflare.com, linux-driver@qlogic.com, computersforpeace@gmail.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-wireless@vger.kernel.org, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, lars@metafoo.de, johannes.berg@intel.com Subject: [PATCH 0776/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:45:17 +0800 Message-Id: <20160802114517.1442-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: netdev-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: netdev@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/net/wireless/intel/ipw2x00/libipw_module.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/intel/ipw2x00/libipw_module.c b/drivers/net/wireless/intel/ipw2x00/libipw_module.c index 60f2874..b8435fe 100644 --- a/drivers/net/wireless/intel/ipw2x00/libipw_module.c +++ b/drivers/net/wireless/intel/ipw2x00/libipw_module.c @@ -313,7 +313,7 @@ static void __exit libipw_exit(void) #ifdef CONFIG_LIBIPW_DEBUG #include -module_param(debug, int, 0444); +module_param(debug, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug, "debug output mask"); #endif /* CONFIG_LIBIPW_DEBUG */