From patchwork Tue Aug 2 11:39:01 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Baole Ni X-Patchwork-Id: 655007 X-Patchwork-Delegate: davem@davemloft.net Return-Path: X-Original-To: patchwork-incoming@ozlabs.org Delivered-To: patchwork-incoming@ozlabs.org Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by ozlabs.org (Postfix) with ESMTP id 3s3hLH1tJcz9tTC for ; Wed, 3 Aug 2016 02:22:15 +1000 (AEST) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935076AbcHBQTQ (ORCPT ); Tue, 2 Aug 2016 12:19:16 -0400 Received: from mga04.intel.com ([192.55.52.120]:58553 "EHLO mga04.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934277AbcHBMRf (ORCPT ); Tue, 2 Aug 2016 08:17:35 -0400 Received: from orsmga002.jf.intel.com ([10.7.209.21]) by fmsmga104.fm.intel.com with ESMTP; 02 Aug 2016 05:16:42 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028272044" Received: from shsibuild003.sh.intel.com ([10.239.146.225]) by orsmga002.jf.intel.com with ESMTP; 02 Aug 2016 05:16:40 -0700 From: Baole Ni To: sgoutham@cavium.com, rric@kernel.org, felix.manlunas@caviumnetworks.com, raghu.vatsavayi@caviumnetworks.com, computersforpeace@gmail.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-arm-kernel@lists.infradead.org, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, mugunthanvnm@ti.com, felipe.balbi@linux.intel.com, fw@strlen.de Subject: [PATCH 0712/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:39:01 +0800 Message-Id: <20160802113901.29520-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: netdev-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: netdev@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/net/ethernet/cavium/thunder/nicvf_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/ethernet/cavium/thunder/nicvf_main.c b/drivers/net/ethernet/cavium/thunder/nicvf_main.c index a19e73f..f480cde 100644 --- a/drivers/net/ethernet/cavium/thunder/nicvf_main.c +++ b/drivers/net/ethernet/cavium/thunder/nicvf_main.c @@ -43,7 +43,7 @@ MODULE_VERSION(DRV_VERSION); MODULE_DEVICE_TABLE(pci, nicvf_id_table); static int debug = 0x00; -module_param(debug, int, 0644); +module_param(debug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug, "Debug message level bitmap"); static int cpi_alg = CPI_ALG_NONE;