diff mbox

xt_helper: use sizeof()

Message ID 1279873323-15544-1-git-send-email-xiaosuo@gmail.com
State Not Applicable, archived
Delegated to: David Miller
Headers show

Commit Message

Changli Gao July 23, 2010, 8:22 a.m. UTC
use sizeof() to improve the readability.

Signed-off-by: Changli Gao <xiaosuo@gmail.com>
----
 net/netfilter/xt_helper.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Comments

Patrick McHardy July 23, 2010, 11:53 a.m. UTC | #1
On 23.07.2010 10:22, Changli Gao wrote:
> use sizeof() to improve the readability.
> 

Applied, thanks.

One more request about your changelogs though: please use capital
letters at the beginning of new sentences in the patch description.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Patrick McHardy July 23, 2010, 11:56 a.m. UTC | #2
On 23.07.2010 13:53, Patrick McHardy wrote:
> On 23.07.2010 10:22, Changli Gao wrote:
>> use sizeof() to improve the readability.
>>
> 
> Applied, thanks.

I see that you sent another patch for this using a different
subject. Please state it clearly when you wish to withdraw
a patch. I've backed it out again.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/net/netfilter/xt_helper.c b/net/netfilter/xt_helper.c
index 9f4ab00..805c9f6 100644
--- a/net/netfilter/xt_helper.c
+++ b/net/netfilter/xt_helper.c
@@ -65,7 +65,7 @@  static int helper_mt_check(const struct xt_mtchk_param *par)
 			par->family);
 		return ret;
 	}
-	info->name[29] = '\0';
+	info->name[sizeof(info->name) - 1] = '\0';
 	return 0;
 }