diff mbox

netem: fix installs of dist files

Message ID 1276131129-18079-1-git-send-email-vapier@gentoo.org
State Accepted, archived
Delegated to: stephen hemminger
Headers show

Commit Message

Mike Frysinger June 10, 2010, 12:52 a.m. UTC
The tc program searches LIBDIR by default for the .dist files, and that
defaults to /usr/lib.  But the netem subdir has /lib/ hardcoded which
means the default build+install results in the files not being found.

Further, these are plain text files which are read at runtime, so it
doesn't make sense to give them executable bits.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 netem/Makefile |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Comments

stephen hemminger Aug. 1, 2010, 2:33 a.m. UTC | #1
On Wed,  9 Jun 2010 20:52:09 -0400
Mike Frysinger <vapier@gentoo.org> wrote:

> The tc program searches LIBDIR by default for the .dist files, and that
> defaults to /usr/lib.  But the netem subdir has /lib/ hardcoded which
> means the default build+install results in the files not being found.
> 
> Further, these are plain text files which are read at runtime, so it
> doesn't make sense to give them executable bits.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
> ---
>  netem/Makefile |    4 ++--
>  1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/netem/Makefile b/netem/Makefile
> index b6ccfc6..e52e125 100644
> --- a/netem/Makefile
> +++ b/netem/Makefile
> @@ -20,9 +20,9 @@ stats: stats.c
>  	$(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
>  
>  install: all
> -	mkdir -p $(DESTDIR)/lib/tc
> +	mkdir -p $(DESTDIR)$(LIBDIR)/tc
>  	for i in $(DISTDATA); \
> -	do install -m 755 $$i $(DESTDIR)/lib/tc; \
> +	do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
>  	done
>  
>  clean:


Applied
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/netem/Makefile b/netem/Makefile
index b6ccfc6..e52e125 100644
--- a/netem/Makefile
+++ b/netem/Makefile
@@ -20,9 +20,9 @@  stats: stats.c
 	$(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
 
 install: all
-	mkdir -p $(DESTDIR)/lib/tc
+	mkdir -p $(DESTDIR)$(LIBDIR)/tc
 	for i in $(DISTDATA); \
-	do install -m 755 $$i $(DESTDIR)/lib/tc; \
+	do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
 	done
 
 clean: