mbox series

[mlx5-next,00/18] Mellanox, mlx5 E-Switch and low level updates

Message ID 20190628223516.9368-1-saeedm@mellanox.com
Headers show
Series Mellanox, mlx5 E-Switch and low level updates | expand

Message

Saeed Mahameed June 28, 2019, 10:35 p.m. UTC
Hi All,

This series includes some low level updates mainly in the E-Switch
netdev and rdma vport representors areas.

From Parav and Huy:
 1) Added hardware bits and structures definitions for sub-functions
 2) Small code cleanup and improvement for PF pci driver.

From Bodong:
 3) Use the correct name semantics of vport index and vport number
 4) Cleanup the rep and netdev reference when unloading IB rep.
 5) Bluefield (ECPF) updates and refactoring for better E-Switch 
    management on ECPF embedded CPU NIC:
    5.1) Consolidate querying eswitch number of VFs
    5.2) Register event handler at the correct E-Switch init stage
    5.3) Setup PF's inline mode and vlan pop when the ECPF is the
         E-Swtich manager ( the host PF is basically a VF ).
    5.4) Handle Vport UC address changes in switchdev mode.

From Shay:
 6) Add support for MCQI and MCQS hardware registers.

In case of no objections these patches will be applied to mlx5-next and
will be sent later as pull request to both rdma-next and net-next trees.

Thanks,
Saeed.

---

Bodong Wang (12):
  net/mlx5: E-Switch, Use vport index when init rep
  {IB, net}/mlx5: E-Switch, Use index of rep for vport to IB port
    mapping
  RDMA/mlx5: Cleanup rep when doing unload
  net/mlx5: Don't handle VF func change if host PF is disabled
  net/mlx5: E-Switch, Use correct flags when configuring vlan
  net/mlx5: Handle host PF vport mac/guid for ECPF
  net/mlx5: E-Switch, Refactor eswitch SR-IOV interface
  net/mlx5: E-Switch, Consolidate eswitch function number of VFs
  net/mlx5: E-Switch, Reg/unreg function changed event at correct stage
  net/mlx5: E-Switch, Use iterator for vlan and min-inline setups
  net/mlx5: E-Switch, Consider host PF for inline mode and vlan pop
  net/mlx5: E-Switch, Handle UC address change in switchdev mode

Huy Nguyen (1):
  net/mlx5: Rename mlx5_pci_dev_type to mlx5_coredev_type

Parav Pandit (4):
  net/mlx5: Add hardware definitions for sub functions
  net/mlx5: Move pci status reg access mutex to mlx5_pci_init
  net/mlx5: Limit scope of mlx5_get_next_phys_dev() to PCI PF devices
  net/mlx5: Reduce dependency on enabled_vfs counter and num_vfs

Shay Agroskin (1):
  net/mlx5: Added MCQI and MCQS registers' description to ifc

 drivers/infiniband/hw/mlx5/ib_rep.c           |  22 +-
 drivers/infiniband/hw/mlx5/ib_rep.h           |   2 +-
 drivers/infiniband/hw/mlx5/main.c             |   2 +-
 drivers/infiniband/hw/mlx5/mlx5_ib.h          |   1 -
 drivers/net/ethernet/mellanox/mlx5/core/dev.c |   9 +-
 .../ethernet/mellanox/mlx5/core/en_dcbnl.c    |   2 +-
 .../net/ethernet/mellanox/mlx5/core/en_main.c |   4 +-
 .../net/ethernet/mellanox/mlx5/core/en_rep.c  |   8 +-
 .../net/ethernet/mellanox/mlx5/core/en_tc.c   |   2 +-
 .../net/ethernet/mellanox/mlx5/core/eswitch.c | 151 ++++++++------
 .../net/ethernet/mellanox/mlx5/core/eswitch.h |  44 +++-
 .../mellanox/mlx5/core/eswitch_offloads.c     | 196 ++++++++----------
 .../ethernet/mellanox/mlx5/core/fpga/conn.c   |   2 +-
 drivers/net/ethernet/mellanox/mlx5/core/lag.c |   4 +-
 .../net/ethernet/mellanox/mlx5/core/main.c    |   7 +-
 .../net/ethernet/mellanox/mlx5/core/rdma.c    |   2 +-
 .../net/ethernet/mellanox/mlx5/core/sriov.c   |  27 +--
 .../net/ethernet/mellanox/mlx5/core/vport.c   |  28 ++-
 include/linux/mlx5/driver.h                   |  13 +-
 include/linux/mlx5/eswitch.h                  |   8 +-
 include/linux/mlx5/mlx5_ifc.h                 | 161 +++++++++++++-
 include/linux/mlx5/vport.h                    |   4 +-
 22 files changed, 446 insertions(+), 253 deletions(-)

Comments

Saeed Mahameed July 1, 2019, 11:46 p.m. UTC | #1
On Fri, Jun 28, 2019 at 3:35 PM Saeed Mahameed <saeedm@mellanox.com> wrote:
>
> Hi All,
>
> This series includes some low level updates mainly in the E-Switch
> netdev and rdma vport representors areas.
>
> From Parav and Huy:
>  1) Added hardware bits and structures definitions for sub-functions
>  2) Small code cleanup and improvement for PF pci driver.
>
> From Bodong:
>  3) Use the correct name semantics of vport index and vport number
>  4) Cleanup the rep and netdev reference when unloading IB rep.
>  5) Bluefield (ECPF) updates and refactoring for better E-Switch
>     management on ECPF embedded CPU NIC:
>     5.1) Consolidate querying eswitch number of VFs
>     5.2) Register event handler at the correct E-Switch init stage
>     5.3) Setup PF's inline mode and vlan pop when the ECPF is the
>          E-Swtich manager ( the host PF is basically a VF ).
>     5.4) Handle Vport UC address changes in switchdev mode.
>
> From Shay:
>  6) Add support for MCQI and MCQS hardware registers.
>
> In case of no objections these patches will be applied to mlx5-next and
> will be sent later as pull request to both rdma-next and net-next trees.

Applied to mlx5-next,

Thanks!