mbox series

[net,0/2] sockmap fixes

Message ID 20171027163830.28498.82997.stgit@john-Precision-Tower-5810
Headers show
Series sockmap fixes | expand

Message

John Fastabend Oct. 27, 2017, 4:45 p.m. UTC
Last two fixes (as far as I know) for sockmap code this round.

First, we are using the qdisc cb structure when making the data end
calculation. This is really just wrong so, store it with the other
metadata in the correct tcp_skb_cb sturct to avoid breaking things.

Next, with recent work to attach multiple programs to a cgroup a
specific enumeration of return codes was agreed upon. However,
I wrote the sk_skb program types before seeing this work and used
a different convention. Patch 2 in the series aligns the return
codes to avoid breaking with this infrastructure and also aligns
with other programming conventions to avoid being the odd duck out
forcing programs to remember SK_SKB programs are different. Pusing
to net because its a user visible change. With this SK_SKB program
return codes are the same as other cgroup program types.

Thanks!
John

---

John Fastabend (2):
      bpf: bpf_compute_data uses incorrect cb structure
      bpf: rename sk_actions to align with bpf infrastructure


 include/net/tcp.h              |    1 +
 include/uapi/linux/bpf.h       |    6 +++---
 kernel/bpf/sockmap.c           |   15 ++++++++++++---
 net/core/filter.c              |   32 +++++++++++++++++++++++++++++---
 tools/include/uapi/linux/bpf.h |    4 ++--
 5 files changed, 47 insertions(+), 11 deletions(-)

--
Signature

Comments

David Miller Oct. 29, 2017, 2:19 a.m. UTC | #1
From: John Fastabend <john.fastabend@gmail.com>
Date: Fri, 27 Oct 2017 09:45:16 -0700

> Last two fixes (as far as I know) for sockmap code this round.
> 
> First, we are using the qdisc cb structure when making the data end
> calculation. This is really just wrong so, store it with the other
> metadata in the correct tcp_skb_cb sturct to avoid breaking things.
> 
> Next, with recent work to attach multiple programs to a cgroup a
> specific enumeration of return codes was agreed upon. However,
> I wrote the sk_skb program types before seeing this work and used
> a different convention. Patch 2 in the series aligns the return
> codes to avoid breaking with this infrastructure and also aligns
> with other programming conventions to avoid being the odd duck out
> forcing programs to remember SK_SKB programs are different. Pusing
> to net because its a user visible change. With this SK_SKB program
> return codes are the same as other cgroup program types.

Series applied, thanks a lot John.