mbox series

[V2,net-next,00/14] ENA features and cosmetic changes

Message ID 1590138545-501-1-git-send-email-akiyano@amazon.com
Headers show
Series ENA features and cosmetic changes | expand

Message

Kiyanovski, Arthur May 22, 2020, 9:08 a.m. UTC
From: Arthur Kiyanovski <akiyano@amazon.com>

Diff from V1 of this patchset:
Removed error prints patch

This patchset includes:
1. new rx offset feature
2. reduction of the driver load time
3. multiple cosmetic changes to the code

Arthur Kiyanovski (14):
  net: ena: add support for the rx offset feature
  net: ena: rename ena_com_free_desc to make API more uniform
  net: ena: use explicit variable size for clarity
  net: ena: fix ena_com_comp_status_to_errno() return value
  net: ena: simplify ena_com_update_intr_delay_resolution()
  net: ena: cosmetic: rename ena_update_tx/rx_rings_intr_moderation()
  net: ena: cosmetic: set queue sizes to u32 for consistency
  net: ena: cosmetic: fix spelling and grammar mistakes in comments
  net: ena: cosmetic: fix line break issues
  net: ena: cosmetic: remove unnecessary code
  net: ena: cosmetic: code reorderings
  net: ena: cosmetic: fix spacing issues
  net: ena: cosmetic: minor code changes
  net: ena: reduce driver load time

 .../net/ethernet/amazon/ena/ena_admin_defs.h  | 11 ++-
 drivers/net/ethernet/amazon/ena/ena_com.c     | 85 ++++++++++---------
 drivers/net/ethernet/amazon/ena/ena_com.h     | 35 ++++----
 .../net/ethernet/amazon/ena/ena_common_defs.h |  2 +-
 drivers/net/ethernet/amazon/ena/ena_eth_com.c | 26 +++---
 drivers/net/ethernet/amazon/ena/ena_eth_com.h |  7 +-
 .../net/ethernet/amazon/ena/ena_eth_io_defs.h |  6 +-
 drivers/net/ethernet/amazon/ena/ena_ethtool.c | 19 ++---
 drivers/net/ethernet/amazon/ena/ena_netdev.c  | 39 +++++----
 drivers/net/ethernet/amazon/ena/ena_netdev.h  | 10 +--
 .../net/ethernet/amazon/ena/ena_regs_defs.h   |  2 +-
 11 files changed, 131 insertions(+), 111 deletions(-)

Comments

Jakub Kicinski May 22, 2020, 5:48 p.m. UTC | #1
On Fri, 22 May 2020 12:08:51 +0300 akiyano@amazon.com wrote:
> From: Arthur Kiyanovski <akiyano@amazon.com>
> 
> Diff from V1 of this patchset:
> Removed error prints patch
> 
> This patchset includes:
> 1. new rx offset feature
> 2. reduction of the driver load time
> 3. multiple cosmetic changes to the code

Acked-by: Jakub Kicinski <kuba@kernel.org>
David Miller May 22, 2020, 9:13 p.m. UTC | #2
From: <akiyano@amazon.com>
Date: Fri, 22 May 2020 12:08:51 +0300

> From: Arthur Kiyanovski <akiyano@amazon.com>
> 
> Diff from V1 of this patchset:
> Removed error prints patch
> 
> This patchset includes:
> 1. new rx offset feature
> 2. reduction of the driver load time
> 3. multiple cosmetic changes to the code

Series applied, thanks.