mbox series

[net-next,00/10] tipc: de-generealize topology server

Message ID 1518687651-26561-1-git-send-email-jon.maloy@ericsson.com
Headers show
Series tipc: de-generealize topology server | expand

Message

Jon Maloy Feb. 15, 2018, 9:40 a.m. UTC
The topology server is partially based on a template that is much
more generic than what we need. This results in a code that is
unnecessarily hard to follow and keeping bug free.

We now take the consequence of the fact that we only have one such
server in TIPC, - with no prospects for introducing any more, and
adapt the code to the specialized task is really is doing.


Jon Maloy (10):
  tipc: remove redundant code in topology server
  tipc: remove unnecessary function pointers
  tipc: eliminate struct tipc_subscriber
  tipc: simplify interaction between subscription and topology
    connection
  tipc: simplify endianness handling in topology subscriber
  tipc: collapse subscription creation functions
  tipc: some prefix changes
  tipc: make struct tipc_server private for server.c
  tipc: separate topology server listener socket from subcsriber sockets
  tipc: rename tipc_server to tipc_topsrv

 net/tipc/Makefile     |   2 +-
 net/tipc/core.h       |   6 +-
 net/tipc/group.c      |   2 +-
 net/tipc/name_table.c |  73 +++---
 net/tipc/name_table.h |   2 +-
 net/tipc/server.c     | 710 --------------------------------------------------
 net/tipc/server.h     | 103 --------
 net/tipc/subscr.c     | 361 +++++--------------------
 net/tipc/subscr.h     |  66 +++--
 net/tipc/topsrv.c     | 702 +++++++++++++++++++++++++++++++++++++++++++++++++
 net/tipc/topsrv.h     |  54 ++++
 11 files changed, 912 insertions(+), 1169 deletions(-)
 delete mode 100644 net/tipc/server.c
 delete mode 100644 net/tipc/server.h
 create mode 100644 net/tipc/topsrv.c
 create mode 100644 net/tipc/topsrv.h

Comments

David Miller Feb. 16, 2018, 8:29 p.m. UTC | #1
From: Jon Maloy <jon.maloy@ericsson.com>
Date: Thu, 15 Feb 2018 10:40:41 +0100

> The topology server is partially based on a template that is much
> more generic than what we need. This results in a code that is
> unnecessarily hard to follow and keeping bug free.
> 
> We now take the consequence of the fact that we only have one such
> server in TIPC, - with no prospects for introducing any more, and
> adapt the code to the specialized task is really is doing.

Nice cleanup, series applied, thanks Jon.