diff mbox

[v2,2/3] ASoC: Tegra+WM903 machine: Set the new fully_routed flag

Message ID 1322077326-5538-2-git-send-email-swarren@nvidia.com
State Accepted, archived
Headers show

Commit Message

Stephen Warren Nov. 23, 2011, 7:42 p.m. UTC
Set card.fully_routed to request the ASoC core calculated unused codec
pins, and call snd_soc_dapm_nc_pin() for them. Remove the open-coded
calls.

v2: Rename flag from auto_nc_pins to fully_routed. Adjust description.

Signed-off-by: Stephen Warren <swarren@nvidia.com>
---
 sound/soc/tegra/tegra_wm8903.c |   22 +---------------------
 1 files changed, 1 insertions(+), 21 deletions(-)

Comments

Mark Brown Nov. 23, 2011, 9:32 p.m. UTC | #1
On Wed, Nov 23, 2011 at 12:42:05PM -0700, Stephen Warren wrote:

> v2: Rename flag from auto_nc_pins to fully_routed. Adjust description.
> 
> Signed-off-by: Stephen Warren <swarren@nvidia.com>
> ---
>  sound/soc/tegra/tegra_wm8903.c |   22 +---------------------
>  1 files changed, 1 insertions(+), 21 deletions(-)

Things like your above "v2" line really ought to go here below the ---
so they're automatically cut from the changelog by the tools.
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Stephen Warren Nov. 23, 2011, 9:56 p.m. UTC | #2
Mark Brown wrote at Wednesday, November 23, 2011 2:32 PM:
> On Wed, Nov 23, 2011 at 12:42:05PM -0700, Stephen Warren wrote:
> 
> > v2: Rename flag from auto_nc_pins to fully_routed. Adjust description.
> >
> > Signed-off-by: Stephen Warren <swarren@nvidia.com>
> > ---
> >  sound/soc/tegra/tegra_wm8903.c |   22 +---------------------
> >  1 files changed, 1 insertions(+), 21 deletions(-)
> 
> Things like your above "v2" line really ought to go here below the ---
> so they're automatically cut from the changelog by the tools.

That was deliberate; some advantages:
* Documents the review process in git, potentially giving some insight
  into reasoning behind parts of the patch.
* Allows confirmation that the correct version was checked in.
  (rarely an issue, but occasionally, albeit I haven't seen it in ASoC)

It's been mentioned a couple of times briefly on various lists before,
and while I'm sure it's not standard practice or anything, at least
there are some people supporting it. However, if you prefer, I'll try
to remember to move the changelog for ASoC patches.
Mark Brown Nov. 23, 2011, 10:06 p.m. UTC | #3
On Wed, Nov 23, 2011 at 01:56:14PM -0800, Stephen Warren wrote:

> * Documents the review process in git, potentially giving some insight
>   into reasoning behind parts of the patch.

If this is an issue write better changelogs (with similar reasoning to
why we don't merge incremental versions of the code either; besides
without knowing what the old versions were it's generally not so useful).
The lkml-reference: stuff looks a lot more useful if you really do want
to do that as it'll show the older versions and discussions.

> * Allows confirmation that the correct version was checked in.
>   (rarely an issue, but occasionally, albeit I haven't seen it in ASoC)

Diff is useful for that (especially if people do what I do when I notice
this stuff and manually strip the noise).

> It's been mentioned a couple of times briefly on various lists before,
> and while I'm sure it's not standard practice or anything, at least
> there are some people supporting it. However, if you prefer, I'll try
> to remember to move the changelog for ASoC patches.

I've genuinely never seen this before except where it looked like an
error on the part of the sender.
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/sound/soc/tegra/tegra_wm8903.c b/sound/soc/tegra/tegra_wm8903.c
index 33feee8..b260f54 100644
--- a/sound/soc/tegra/tegra_wm8903.c
+++ b/sound/soc/tegra/tegra_wm8903.c
@@ -331,27 +331,6 @@  static int tegra_wm8903_init(struct snd_soc_pcm_runtime *rtd)
 
 	snd_soc_dapm_force_enable_pin(dapm, "Mic Bias");
 
-	/* FIXME: Calculate automatically based on DAPM routes? */
-	if (!machine_is_harmony())
-		snd_soc_dapm_nc_pin(dapm, "IN1L");
-	if (!machine_is_seaboard() && !machine_is_aebl())
-		snd_soc_dapm_nc_pin(dapm, "IN1R");
-	snd_soc_dapm_nc_pin(dapm, "IN2L");
-	if (!machine_is_kaen())
-		snd_soc_dapm_nc_pin(dapm, "IN2R");
-	snd_soc_dapm_nc_pin(dapm, "IN3L");
-	snd_soc_dapm_nc_pin(dapm, "IN3R");
-
-	if (machine_is_aebl()) {
-		snd_soc_dapm_nc_pin(dapm, "LON");
-		snd_soc_dapm_nc_pin(dapm, "RON");
-		snd_soc_dapm_nc_pin(dapm, "ROP");
-		snd_soc_dapm_nc_pin(dapm, "LOP");
-	} else {
-		snd_soc_dapm_nc_pin(dapm, "LINEOUTR");
-		snd_soc_dapm_nc_pin(dapm, "LINEOUTL");
-	}
-
 	return 0;
 }
 
@@ -375,6 +354,7 @@  static struct snd_soc_card snd_soc_tegra_wm8903 = {
 	.num_controls = ARRAY_SIZE(tegra_wm8903_controls),
 	.dapm_widgets = tegra_wm8903_dapm_widgets,
 	.num_dapm_widgets = ARRAY_SIZE(tegra_wm8903_dapm_widgets),
+	.fully_routed = true,
 };
 
 static __devinit int tegra_wm8903_driver_probe(struct platform_device *pdev)