diff mbox series

[v2] pwm: meson: modify and simplify calculation in meson_pwm_get_state

Message ID f48f17a7-7f50-c5ef-cc8f-007d0cb302b0@gmail.com
State Superseded
Headers show
Series [v2] pwm: meson: modify and simplify calculation in meson_pwm_get_state | expand

Commit Message

Heiner Kallweit May 1, 2023, 2:03 p.m. UTC
I don't see a reason why we should treat the case lo < hi differently
and return 0 as period and duty_cycle. The current logic was added with
c375bcbaabdb ("pwm: meson: Read the full hardware state in
meson_pwm_get_state()"), Martin as original author doesn't remember why
it was implemented this way back then.
So let's handle it as normal use case and also remove the optimization
for lo == 0. I think the improved readability is worth it.

Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
---
v2:
- improve commit description
---
 drivers/pwm/pwm-meson.c | 14 ++------------
 1 file changed, 2 insertions(+), 12 deletions(-)

Comments

Uwe Kleine-König May 1, 2023, 6:07 p.m. UTC | #1
On Mon, May 01, 2023 at 04:03:16PM +0200, Heiner Kallweit wrote:
> I don't see a reason why we should treat the case lo < hi differently
> and return 0 as period and duty_cycle. The current logic was added with
> c375bcbaabdb ("pwm: meson: Read the full hardware state in
> meson_pwm_get_state()"), Martin as original author doesn't remember why
> it was implemented this way back then.
> So let's handle it as normal use case and also remove the optimization
> for lo == 0. I think the improved readability is worth it.
> 
> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
> ---
> v2:
> - improve commit description
> ---
>  drivers/pwm/pwm-meson.c | 14 ++------------
>  1 file changed, 2 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/pwm/pwm-meson.c b/drivers/pwm/pwm-meson.c
> index 5732300eb..3865538dd 100644
> --- a/drivers/pwm/pwm-meson.c
> +++ b/drivers/pwm/pwm-meson.c
> @@ -351,18 +351,8 @@ static int meson_pwm_get_state(struct pwm_chip *chip, struct pwm_device *pwm,
>  	channel->lo = FIELD_GET(PWM_LOW_MASK, value);
>  	channel->hi = FIELD_GET(PWM_HIGH_MASK, value);
>  
> -	if (channel->lo == 0) {
> -		state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->hi);
> -		state->duty_cycle = state->period;
> -	} else if (channel->lo >= channel->hi) {
> -		state->period = meson_pwm_cnt_to_ns(chip, pwm,
> -						    channel->lo + channel->hi);
> -		state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm,
> -							channel->hi);
> -	} else {
> -		state->period = 0;
> -		state->duty_cycle = 0;
> -	}

The last else branch is even wrong, isn't it? .apply() can for a greater
than 50% relative duty cycle well have lo < hi, right? So this is not a
mere optimisation but a fix?!

> +	state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->lo + channel->hi);
> +	state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, channel->hi);

Note that meson_pwm_calc() has a similar construct that can be
simplified in a similar way. All three variants have

	channel->pre_div = pre_div;

and the last else branch is universal and can replace the others.

Another issue I just spotted is that

	duty = state->duty_cycle

is wrong for state->duty_cycle > UINT_MAX. (Ditto the assignment to
period.) Making both duty and period u64 shoudl fix that. After that
duty_cnt > 0xffff cannot happen as the core ensures that duty_cycle <=
period.

Having said that, the proposed change here is an improvement, so:

Reviewed-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>

I also suggest to add a Fixes line, i.e.

Fixes: c375bcbaabdb ("pwm: meson: Read the full hardware state in meson_pwm_get_state()")

Best regards
Uwe
Heiner Kallweit May 2, 2023, 8:27 p.m. UTC | #2
On 01.05.2023 20:07, Uwe Kleine-König wrote:
> On Mon, May 01, 2023 at 04:03:16PM +0200, Heiner Kallweit wrote:
>> I don't see a reason why we should treat the case lo < hi differently
>> and return 0 as period and duty_cycle. The current logic was added with
>> c375bcbaabdb ("pwm: meson: Read the full hardware state in
>> meson_pwm_get_state()"), Martin as original author doesn't remember why
>> it was implemented this way back then.
>> So let's handle it as normal use case and also remove the optimization
>> for lo == 0. I think the improved readability is worth it.
>>
>> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
>> ---
>> v2:
>> - improve commit description
>> ---
>>  drivers/pwm/pwm-meson.c | 14 ++------------
>>  1 file changed, 2 insertions(+), 12 deletions(-)
>>
>> diff --git a/drivers/pwm/pwm-meson.c b/drivers/pwm/pwm-meson.c
>> index 5732300eb..3865538dd 100644
>> --- a/drivers/pwm/pwm-meson.c
>> +++ b/drivers/pwm/pwm-meson.c
>> @@ -351,18 +351,8 @@ static int meson_pwm_get_state(struct pwm_chip *chip, struct pwm_device *pwm,
>>  	channel->lo = FIELD_GET(PWM_LOW_MASK, value);
>>  	channel->hi = FIELD_GET(PWM_HIGH_MASK, value);
>>  
>> -	if (channel->lo == 0) {
>> -		state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->hi);
>> -		state->duty_cycle = state->period;
>> -	} else if (channel->lo >= channel->hi) {
>> -		state->period = meson_pwm_cnt_to_ns(chip, pwm,
>> -						    channel->lo + channel->hi);
>> -		state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm,
>> -							channel->hi);
>> -	} else {
>> -		state->period = 0;
>> -		state->duty_cycle = 0;
>> -	}
> 
> The last else branch is even wrong, isn't it? .apply() can for a greater
> than 50% relative duty cycle well have lo < hi, right? So this is not a
> mere optimisation but a fix?!
> 

I *think* too that it's wrong. However I have no test hw and I'm not aware
of any problem caused by the current code. Therefore I was reluctant to make
the patch a fix.

>> +	state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->lo + channel->hi);
>> +	state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, channel->hi);
> 
> Note that meson_pwm_calc() has a similar construct that can be
> simplified in a similar way. All three variants have
> 
> 	channel->pre_div = pre_div;
> 
The pre_div member will be gone anyway with a patch series that is in
discussion currently ("make full use of CCF").

> and the last else branch is universal and can replace the others.
> 
> Another issue I just spotted is that
> 
> 	duty = state->duty_cycle
> 
> is wrong for state->duty_cycle > UINT_MAX. (Ditto the assignment to
> period.) Making both duty and period u64 shoudl fix that. After that
> duty_cnt > 0xffff cannot happen as the core ensures that duty_cycle <=
> period.
> 
I saw that one too. It's something for a follow-up patch.

> Having said that, the proposed change here is an improvement, so:
> 
> Reviewed-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
> 
> I also suggest to add a Fixes line, i.e.
> 
> Fixes: c375bcbaabdb ("pwm: meson: Read the full hardware state in meson_pwm_get_state()")
> 
OK

> Best regards
> Uwe
> 
Heiner
diff mbox series

Patch

diff --git a/drivers/pwm/pwm-meson.c b/drivers/pwm/pwm-meson.c
index 5732300eb..3865538dd 100644
--- a/drivers/pwm/pwm-meson.c
+++ b/drivers/pwm/pwm-meson.c
@@ -351,18 +351,8 @@  static int meson_pwm_get_state(struct pwm_chip *chip, struct pwm_device *pwm,
 	channel->lo = FIELD_GET(PWM_LOW_MASK, value);
 	channel->hi = FIELD_GET(PWM_HIGH_MASK, value);
 
-	if (channel->lo == 0) {
-		state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->hi);
-		state->duty_cycle = state->period;
-	} else if (channel->lo >= channel->hi) {
-		state->period = meson_pwm_cnt_to_ns(chip, pwm,
-						    channel->lo + channel->hi);
-		state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm,
-							channel->hi);
-	} else {
-		state->period = 0;
-		state->duty_cycle = 0;
-	}
+	state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->lo + channel->hi);
+	state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, channel->hi);
 
 	state->polarity = PWM_POLARITY_NORMAL;