diff mbox series

[1/2] PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX

Message ID 20230731012550.728070-2-dlemoal@kernel.org
State New
Headers show
Series Cleanup IRQ type definitions | expand

Commit Message

Damien Le Moal July 31, 2023, 1:25 a.m. UTC
From: Bjorn Helgaas <helgaas@kernel.org>

Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX to be more explicit about the type
of IRQ being referenced as well as to match the PCI specifications
terms. The macro PCI_IRQ_LEGACY is redefined as an alias to PCI_IRQ_INTX
to avoid the need for doing the renaming tree-wide. New drivers and new
code should now prefer using PCI_IRQ_INTX instead of PCI_IRQ_LEGACY.

Signed-off-by: Bjorn Helgaas <helgaas@kernel.org>
Signed-off-by: Damien Le Moal <dlemoal@kernel.org>
---
 include/linux/pci.h | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Bjorn Helgaas Aug. 1, 2023, 9:06 p.m. UTC | #1
[+cc Krzysztof]

On Mon, Jul 31, 2023 at 10:25:49AM +0900, Damien Le Moal wrote:
> From: Bjorn Helgaas <helgaas@kernel.org>
> 
> Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX to be more explicit about the type
> of IRQ being referenced as well as to match the PCI specifications
> terms. The macro PCI_IRQ_LEGACY is redefined as an alias to PCI_IRQ_INTX
> to avoid the need for doing the renaming tree-wide. New drivers and new
> code should now prefer using PCI_IRQ_INTX instead of PCI_IRQ_LEGACY.
> 
> Signed-off-by: Bjorn Helgaas <helgaas@kernel.org>

Looks good to me, but instead of the kernel.org address, please use:

  Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>

Also:

  Redefine PCI_IRQ_LEGACY as an alias to PCI_IRQ_INTX to avoid the
  need for doing the renaming tree-wide.

ISTR other pci/controller/ patches that may come on top of these?  If
so, probably makes sense for Krzysztof to apply these?

> Signed-off-by: Damien Le Moal <dlemoal@kernel.org>
> ---
>  include/linux/pci.h | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/include/linux/pci.h b/include/linux/pci.h
> index 0ff7500772e6..7692d73719e0 100644
> --- a/include/linux/pci.h
> +++ b/include/linux/pci.h
> @@ -1048,11 +1048,13 @@ enum {
>  	PCI_SCAN_ALL_PCIE_DEVS	= 0x00000040,	/* Scan all, not just dev 0 */
>  };
>  
> -#define PCI_IRQ_LEGACY		(1 << 0) /* Allow legacy interrupts */
> +#define PCI_IRQ_INTX		(1 << 0) /* Allow INTx interrupts */
>  #define PCI_IRQ_MSI		(1 << 1) /* Allow MSI interrupts */
>  #define PCI_IRQ_MSIX		(1 << 2) /* Allow MSI-X interrupts */
>  #define PCI_IRQ_AFFINITY	(1 << 3) /* Auto-assign affinity */
>  
> +#define PCI_IRQ_LEGACY		PCI_IRQ_INTX	/* prefer PCI_IRQ_INTX */
> +
>  /* These external functions are only available when PCI support is enabled */
>  #ifdef CONFIG_PCI
>  
> -- 
> 2.41.0
>
diff mbox series

Patch

diff --git a/include/linux/pci.h b/include/linux/pci.h
index 0ff7500772e6..7692d73719e0 100644
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
@@ -1048,11 +1048,13 @@  enum {
 	PCI_SCAN_ALL_PCIE_DEVS	= 0x00000040,	/* Scan all, not just dev 0 */
 };
 
-#define PCI_IRQ_LEGACY		(1 << 0) /* Allow legacy interrupts */
+#define PCI_IRQ_INTX		(1 << 0) /* Allow INTx interrupts */
 #define PCI_IRQ_MSI		(1 << 1) /* Allow MSI interrupts */
 #define PCI_IRQ_MSIX		(1 << 2) /* Allow MSI-X interrupts */
 #define PCI_IRQ_AFFINITY	(1 << 3) /* Auto-assign affinity */
 
+#define PCI_IRQ_LEGACY		PCI_IRQ_INTX	/* prefer PCI_IRQ_INTX */
+
 /* These external functions are only available when PCI support is enabled */
 #ifdef CONFIG_PCI