diff mbox series

[v2,10/15] mtd: maps: Prepare merging of physmap and physmap_of

Message ID 20181019074908.13226-11-boris.brezillon@bootlin.com
State Accepted
Delegated to: Boris Brezillon
Headers show
Series mtd: maps: physmap cleanups | expand

Commit Message

Boris Brezillon Oct. 19, 2018, 7:49 a.m. UTC
We want to merge the physmap and physmap_of driver, but before we can
do that we must prepare things to create physmap.o out of several .c
files. Rename physmap.c into physmap-core.c and add a new Makefile
rule to create physmap.o (right now it only contains physmap-core.o).

Signed-off-by: Boris Brezillon <boris.brezillon@bootlin.com>
Reviewed-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
Changes in v2:
- Add Ricardo's R-b
---
 drivers/mtd/maps/Makefile                      | 2 ++
 drivers/mtd/maps/{physmap.c => physmap-core.c} | 0
 2 files changed, 2 insertions(+)
 rename drivers/mtd/maps/{physmap.c => physmap-core.c} (100%)
diff mbox series

Patch

diff --git a/drivers/mtd/maps/Makefile b/drivers/mtd/maps/Makefile
index 51acf1fec19b..2574909edffd 100644
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -17,6 +17,8 @@  obj-$(CONFIG_MTD_ICHXROM)	+= ichxrom.o
 obj-$(CONFIG_MTD_CK804XROM)	+= ck804xrom.o
 obj-$(CONFIG_MTD_TSUNAMI)	+= tsunami_flash.o
 obj-$(CONFIG_MTD_PXA2XX)	+= pxa2xx-flash.o
+physmap-objs-y			+= physmap-core.o
+physmap-objs			:= $(physmap-objs-y)
 obj-$(CONFIG_MTD_PHYSMAP)	+= physmap.o
 physmap_of-objs-y		+= physmap_of_core.o
 physmap_of-objs-$(CONFIG_MTD_PHYSMAP_OF_VERSATILE) += physmap_of_versatile.o
diff --git a/drivers/mtd/maps/physmap.c b/drivers/mtd/maps/physmap-core.c
similarity index 100%
rename from drivers/mtd/maps/physmap.c
rename to drivers/mtd/maps/physmap-core.c