mbox

[GIT,PULL] clockevents for 4.1

Message ID 5519AEB2.8050306@linaro.org
State New
Headers show

Pull-request

http://git.linaro.org/people/daniel.lezcano/linux.git clockevents/4.1

Message

Daniel Lezcano March 30, 2015, 8:14 p.m. UTC
Hi Thomas, Ingo,

this pull request contains the following changes for 4.1:

  - Made IO endian agnostic for at91 and dw apb timers (Ben Dooks)

  - Maintained tegra endianess (Dmitry Osipenko)

  - Enabled the sun4i / sun5i timer for sched_clock, all others winner 
boards have the arch arm timer which is more accurate (Hans de Goede)

  - Renamed the arch arm timer function name to reflect better its 
purpose (Laurent Pinchart)

  - Cleaned up the sun5i timer code, replaced the setup_irq by the 
request_irq function and handled the parent clock frequency change with 
the frequency notifiers (Maxime Ripard)

  - Fixed features declaration for the efm32 timer (Viresh Kumar)

Thanks !

   -- Daniel

The following changes since commit 2557d215a36d18c8bbaa35f65749349ac603360b:

   Merge branch 'timers/urgent' into timers/core, to pick up fixes 
before applying new changes (2015-03-17 11:11:24 +0100)

are available in the git repository at:

   http://git.linaro.org/people/daniel.lezcano/linux.git clockevents/4.1

for you to fetch changes up to 0bb4ef6f7c56cdf606a5e501cf1597f40c9028eb

   clocksource: efm32: Use CLOCK_EVT_FEAT_PERIODIC for defining features 
(2015-03-30 15:27:24 +0200)

----------------------------------------------------------------
Ben Dooks (2):
       clocksource: at91: Make IO endian agnostic
       clocksource: dw_apb_timer_of: Make IO endian agnostic

Dmitry Osipenko (1):
       clocksource: tegra: Maintain CPU endianness

Hans de Goede (1):
       clocksource: sun4i-timer: Only register a sched_clock on sun4i 
and sun5i

Laurent Pinchart (1):
       clocksource: arm_arch_timer: Rename arch_timer_probed to reflect 
behaviour

Maxime Ripard (5):
       clocksource: sun5i: Switch to request_irq
       clocksource: sun5i: Use of_io_request_and_map
       clocksource: sun5i: Remove sched_clock
       clocksource: sun5i: Refactor the current code
       clocksource: sun5i: Add clock notifiers

Viresh Kumar (1):
       clocksource: efm32: Use CLOCK_EVT_FEAT_PERIODIC for defining features

  drivers/clocksource/arm_arch_timer.c  |  13 +++++-----
  drivers/clocksource/dw_apb_timer_of.c |   2 +-
  drivers/clocksource/sun4i_timer.c     |  10 +++++++-
  drivers/clocksource/tegra20_timer.c   |   4 ++--
  drivers/clocksource/time-efm32.c      |   2 +-
  drivers/clocksource/timer-atmel-pit.c |   4 ++--
  drivers/clocksource/timer-sun5i.c     | 302 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++--------------------------------------------------------
  7 files changed, 250 insertions(+), 87 deletions(-)

Comments

Ingo Molnar March 31, 2015, 7:14 a.m. UTC | #1
* Daniel Lezcano <daniel.lezcano@linaro.org> wrote:

> From: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>
> 
> The arch_timer_probed function returns whether the given time doesn't
> need to be probed. This can be the case when the timer has been probed
> already, but also when it has no corresponding enabled node in DT.
> 
> Rename the function to arch_timer_need_probe and invert its return value
> to better reflect the function's purpose and behaviour.
> 
> Acked-by: Sudeep Holla <sudeep.holla@arm.com>
> Signed-off-by: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>
> Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
> ---
>  drivers/clocksource/arm_arch_timer.c | 13 +++++++------
>  1 file changed, 7 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/clocksource/arm_arch_timer.c b/drivers/clocksource/arm_arch_timer.c
> index a3025e7..50bb7f2 100644
> --- a/drivers/clocksource/arm_arch_timer.c
> +++ b/drivers/clocksource/arm_arch_timer.c
> @@ -661,17 +661,17 @@ static const struct of_device_id arch_timer_mem_of_match[] __initconst = {
>  };
>  
>  static bool __init
> -arch_timer_probed(int type, const struct of_device_id *matches)
> +arch_timer_need_probe(int type, const struct of_device_id *matches)

If we do a rename we might as well use valid English spelling such as 
'arch_timer_needs_probing()'?

Thanks,

	Ingo
Ingo Molnar March 31, 2015, 7:17 a.m. UTC | #2
* Daniel Lezcano <daniel.lezcano@linaro.org> wrote:

> 
> Hi Thomas, Ingo,
> 
> this pull request contains the following changes for 4.1:
> 
>  - Made IO endian agnostic for at91 and dw apb timers (Ben Dooks)
> 
>  - Maintained tegra endianess (Dmitry Osipenko)
> 
>  - Enabled the sun4i / sun5i timer for sched_clock, all others winner boards
> have the arch arm timer which is more accurate (Hans de Goede)
> 
>  - Renamed the arch arm timer function name to reflect better its purpose
> (Laurent Pinchart)
> 
>  - Cleaned up the sun5i timer code, replaced the setup_irq by the
> request_irq function and handled the parent clock frequency change with the
> frequency notifiers (Maxime Ripard)
> 
>  - Fixed features declaration for the efm32 timer (Viresh Kumar)
> 
> Thanks !

So I had some comments about one of the patches, and fixes to 
changelogs, so I've applied all but the sun4/5i patches from email to 
move things forward.

The sun4/5i patches conflicted - mind reposting those merged on top of 
the latest tip:timers:core tree?

Thanks!

	Ingo
Daniel Lezcano March 31, 2015, 9:37 a.m. UTC | #3
On 03/31/2015 09:17 AM, Ingo Molnar wrote:
>
> * Daniel Lezcano <daniel.lezcano@linaro.org> wrote:
>
>>
>> Hi Thomas, Ingo,
>>
>> this pull request contains the following changes for 4.1:
>>
>>   - Made IO endian agnostic for at91 and dw apb timers (Ben Dooks)
>>
>>   - Maintained tegra endianess (Dmitry Osipenko)
>>
>>   - Enabled the sun4i / sun5i timer for sched_clock, all others winner boards
>> have the arch arm timer which is more accurate (Hans de Goede)
>>
>>   - Renamed the arch arm timer function name to reflect better its purpose
>> (Laurent Pinchart)
>>
>>   - Cleaned up the sun5i timer code, replaced the setup_irq by the
>> request_irq function and handled the parent clock frequency change with the
>> frequency notifiers (Maxime Ripard)
>>
>>   - Fixed features declaration for the efm32 timer (Viresh Kumar)
>>
>> Thanks !
>
> So I had some comments about one of the patches, and fixes to
> changelogs, so I've applied all but the sun4/5i patches from email to
> move things forward.

The subsystem prefix is now 'clocksource/drivers/<name>' ?

> The sun4/5i patches conflicted - mind reposting those merged on top of
> the latest tip:timers:core tree?

Yes, sure. No problem.

Thanks !

   -- Daniel
Ingo Molnar March 31, 2015, 9:42 a.m. UTC | #4
* Daniel Lezcano <daniel.lezcano@linaro.org> wrote:

> On 03/31/2015 09:17 AM, Ingo Molnar wrote:
> >
> >* Daniel Lezcano <daniel.lezcano@linaro.org> wrote:
> >
> >>
> >>Hi Thomas, Ingo,
> >>
> >>this pull request contains the following changes for 4.1:
> >>
> >>  - Made IO endian agnostic for at91 and dw apb timers (Ben Dooks)
> >>
> >>  - Maintained tegra endianess (Dmitry Osipenko)
> >>
> >>  - Enabled the sun4i / sun5i timer for sched_clock, all others winner boards
> >>have the arch arm timer which is more accurate (Hans de Goede)
> >>
> >>  - Renamed the arch arm timer function name to reflect better its purpose
> >>(Laurent Pinchart)
> >>
> >>  - Cleaned up the sun5i timer code, replaced the setup_irq by the
> >>request_irq function and handled the parent clock frequency change with the
> >>frequency notifiers (Maxime Ripard)
> >>
> >>  - Fixed features declaration for the efm32 timer (Viresh Kumar)
> >>
> >>Thanks !
> >
> >So I had some comments about one of the patches, and fixes to
> >changelogs, so I've applied all but the sun4/5i patches from email to
> >move things forward.
> 
> The subsystem prefix is now 'clocksource/drivers/<name>' ?

At least now that we have a good number of clocksource drivers, for 
such pure driver changes that's the logical prefix and makes it easier 
to tell apart clocksource core changes from driver changes.

> > The sun4/5i patches conflicted - mind reposting those merged on 
> > top of the latest tip:timers:core tree?
> 
> Yes, sure. No problem.

Thanks!

	Ingo
Laurent Pinchart March 31, 2015, 2:14 p.m. UTC | #5
Hi Ingo,

On Tuesday 31 March 2015 09:14:52 Ingo Molnar wrote:
> * Daniel Lezcano <daniel.lezcano@linaro.org> wrote:
> > From: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>
> > 
> > The arch_timer_probed function returns whether the given time doesn't
> > need to be probed. This can be the case when the timer has been probed
> > already, but also when it has no corresponding enabled node in DT.
> > 
> > Rename the function to arch_timer_need_probe and invert its return value
> > to better reflect the function's purpose and behaviour.
> > 
> > Acked-by: Sudeep Holla <sudeep.holla@arm.com>
> > Signed-off-by: Laurent Pinchart
> > <laurent.pinchart+renesas@ideasonboard.com>
> > Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
> > ---
> > 
> >  drivers/clocksource/arm_arch_timer.c | 13 +++++++------
> >  1 file changed, 7 insertions(+), 6 deletions(-)
> > 
> > diff --git a/drivers/clocksource/arm_arch_timer.c
> > b/drivers/clocksource/arm_arch_timer.c index a3025e7..50bb7f2 100644
> > --- a/drivers/clocksource/arm_arch_timer.c
> > +++ b/drivers/clocksource/arm_arch_timer.c
> > @@ -661,17 +661,17 @@ static const struct of_device_id
> > arch_timer_mem_of_match[] __initconst = {> 
> >  };
> >  
> >  static bool __init
> > 
> > -arch_timer_probed(int type, const struct of_device_id *matches)
> > +arch_timer_need_probe(int type, const struct of_device_id *matches)
> 
> If we do a rename we might as well use valid English spelling such as
> 'arch_timer_needs_probing()'?

Of course. Should I resend the patch or can you fix that while applying it ?
Ingo Molnar March 31, 2015, 3:49 p.m. UTC | #6
* Laurent Pinchart <laurent.pinchart@ideasonboard.com> wrote:

> Hi Ingo,
> 
> On Tuesday 31 March 2015 09:14:52 Ingo Molnar wrote:
> > * Daniel Lezcano <daniel.lezcano@linaro.org> wrote:
> > > From: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>
> > > 
> > > The arch_timer_probed function returns whether the given time doesn't
> > > need to be probed. This can be the case when the timer has been probed
> > > already, but also when it has no corresponding enabled node in DT.
> > > 
> > > Rename the function to arch_timer_need_probe and invert its return value
> > > to better reflect the function's purpose and behaviour.
> > > 
> > > Acked-by: Sudeep Holla <sudeep.holla@arm.com>
> > > Signed-off-by: Laurent Pinchart
> > > <laurent.pinchart+renesas@ideasonboard.com>
> > > Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
> > > ---
> > > 
> > >  drivers/clocksource/arm_arch_timer.c | 13 +++++++------
> > >  1 file changed, 7 insertions(+), 6 deletions(-)
> > > 
> > > diff --git a/drivers/clocksource/arm_arch_timer.c
> > > b/drivers/clocksource/arm_arch_timer.c index a3025e7..50bb7f2 100644
> > > --- a/drivers/clocksource/arm_arch_timer.c
> > > +++ b/drivers/clocksource/arm_arch_timer.c
> > > @@ -661,17 +661,17 @@ static const struct of_device_id
> > > arch_timer_mem_of_match[] __initconst = {> 
> > >  };
> > >  
> > >  static bool __init
> > > 
> > > -arch_timer_probed(int type, const struct of_device_id *matches)
> > > +arch_timer_need_probe(int type, const struct of_device_id *matches)
> > 
> > If we do a rename we might as well use valid English spelling such as
> > 'arch_timer_needs_probing()'?
> 
> Of course. Should I resend the patch or can you fix that while applying it ?

No need to resend, I've done the rename in the patch.

Thanks,

	Ingo