diff mbox

[PATCHv1,for,soc,5/5] arm: socfpga: Add SMP support for actual socfpga harware

Message ID 20130129184340.GA1962@amd.pavel.ucw.cz
State New
Headers show

Commit Message

Pavel Machek Jan. 29, 2013, 6:43 p.m. UTC
Hi!

> index 9941caa..5b76dd4 100644
> --- a/arch/arm/mach-socfpga/core.h
> +++ b/arch/arm/mach-socfpga/core.h
> @@ -20,7 +20,7 @@
>  #ifndef __MACH_CORE_H
>  #define __MACH_CORE_H
>  
> -extern void secondary_startup(void);
> +extern void v7_secondary_startup(void);
>  extern void __iomem *socfpga_scu_base_addr;
>  

One more thing. v7_secondary_startup() may be too generic name for a
symbol. mach-imx already uses that.

Plus, mach-imx also has the useless #ifdef.

---

Remove useless #ifdef; headsmp.S is only compiled in CONFIG_SMP
configuration.

Signed-off-by: Pavel Machek <pavel@denx.de>



Thanks,
									Pavel
diff mbox

Patch

diff --git a/arch/arm/mach-imx/headsmp.S b/arch/arm/mach-imx/headsmp.S
index 7e49deb..4c9ec06 100644
--- a/arch/arm/mach-imx/headsmp.S
+++ b/arch/arm/mach-imx/headsmp.S
@@ -64,12 +64,10 @@  ENTRY(v7_invalidate_l1)
 	mov	pc, lr
 ENDPROC(v7_invalidate_l1)
 
-#ifdef CONFIG_SMP
 ENTRY(v7_secondary_startup)
 	bl	v7_invalidate_l1
 	b	secondary_startup
 ENDPROC(v7_secondary_startup)
-#endif
 
 #ifdef CONFIG_PM
 /*