diff mbox series

drivers/ata: Improve performance and readability

Message ID OS3P286MB06322266ED2913AF0F6172219E609@OS3P286MB0632.JPNP286.PROD.OUTLOOK.COM
State New
Headers show
Series drivers/ata: Improve performance and readability | expand

Commit Message

Yahu Gao April 21, 2023, 12:54 p.m. UTC
From: Yahu Gao <gaoyh12@lenovo.com>

Replace conditions of avoid issuing [P]IDENTIFY to PMP.

Reviewed-by: Jiwei Sun <sunjw10@lenovo.com>
Signed-off-by: Yahu Gao <gaoyh12@lenovo.com>

Comments

Damien Le Moal April 21, 2023, 10:07 p.m. UTC | #1
On 4/21/23 21:54, Yahu Gao wrote:
> From: Yahu Gao <gaoyh12@lenovo.com>
> 

The patch title should start with:

ata: libata-core: ...

And let's be honest here: this is not the hot path and you are optimizing a
single "if" condition for a series of commands that will take 10s of ms to
execute. So this is *not* about performance. So update the patch title please.

> Replace conditions of avoid issuing [P]IDENTIFY to PMP.
> 
> Reviewed-by: Jiwei Sun <sunjw10@lenovo.com>
> Signed-off-by: Yahu Gao <gaoyh12@lenovo.com>
> 
> diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
> index 14c17c3bda4e..53f65d751189 100644
> --- a/drivers/ata/libata-core.c
> +++ b/drivers/ata/libata-core.c
> @@ -3802,11 +3802,7 @@ int ata_dev_revalidate(struct ata_device *dev, unsigned int new_class,
>  		return -ENODEV;
>  
>  	/* fail early if !ATA && !ATAPI to avoid issuing [P]IDENTIFY to PMP */
> -	if (ata_class_enabled(new_class) &&
> -	    new_class != ATA_DEV_ATA &&
> -	    new_class != ATA_DEV_ATAPI &&
> -	    new_class != ATA_DEV_ZAC &&
> -	    new_class != ATA_DEV_SEMB) {
> +	if (new_class == ATA_DEV_PMP) {

Using a switch-case here may actually make things even more readable.

>  		ata_dev_info(dev, "class mismatch %u != %u\n",
>  			     dev->class, new_class);
>  		rc = -ENODEV;
diff mbox series

Patch

diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
index 14c17c3bda4e..53f65d751189 100644
--- a/drivers/ata/libata-core.c
+++ b/drivers/ata/libata-core.c
@@ -3802,11 +3802,7 @@  int ata_dev_revalidate(struct ata_device *dev, unsigned int new_class,
 		return -ENODEV;
 
 	/* fail early if !ATA && !ATAPI to avoid issuing [P]IDENTIFY to PMP */
-	if (ata_class_enabled(new_class) &&
-	    new_class != ATA_DEV_ATA &&
-	    new_class != ATA_DEV_ATAPI &&
-	    new_class != ATA_DEV_ZAC &&
-	    new_class != ATA_DEV_SEMB) {
+	if (new_class == ATA_DEV_PMP) {
 		ata_dev_info(dev, "class mismatch %u != %u\n",
 			     dev->class, new_class);
 		rc = -ENODEV;