diff mbox series

[v5,2/3] i2c: core: add device-managed version of i2c_new_dummy

Message ID ca47ea36-9b0a-c247-29f5-1c512f52e835@gmail.com
State Superseded
Headers show
Series i2c: introduce devm_i2c_new_dummy and use it in at24 driver | expand

Commit Message

Heiner Kallweit Dec. 15, 2017, 11:05 p.m. UTC
i2c_new_dummy is typically called from the probe function of the
driver for the primary i2c client. It requires calls to
i2c_unregister_device in the error path of the probe function and
in the remove function.
This can be simplified by introducing a device-managed version.

Note the changed error case return value type:
i2c_new_dummy returns NULL whilst devm_new_i2c_dummy returns an ERR_PTR.

Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
---
v2:
- use new function _i2c_new_dummy with detailed error codes
v3:
- no changes
v4:
- reflect renaming to __i2c_new_dummy
v5:
- improve readability by adding struct i2c_dummy_devres
---
 Documentation/driver-model/devres.txt |  3 +++
 drivers/i2c/i2c-core-base.c           | 45 +++++++++++++++++++++++++++++++++++
 include/linux/i2c.h                   |  3 +++
 3 files changed, 51 insertions(+)

Comments

Bartosz Golaszewski Dec. 18, 2017, 5:50 p.m. UTC | #1
2017-12-16 0:05 GMT+01:00 Heiner Kallweit <hkallweit1@gmail.com>:
> i2c_new_dummy is typically called from the probe function of the
> driver for the primary i2c client. It requires calls to
> i2c_unregister_device in the error path of the probe function and
> in the remove function.
> This can be simplified by introducing a device-managed version.
>
> Note the changed error case return value type:
> i2c_new_dummy returns NULL whilst devm_new_i2c_dummy returns an ERR_PTR.
>
> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
> ---
> v2:
> - use new function _i2c_new_dummy with detailed error codes
> v3:
> - no changes
> v4:
> - reflect renaming to __i2c_new_dummy
> v5:
> - improve readability by adding struct i2c_dummy_devres
> ---
>  Documentation/driver-model/devres.txt |  3 +++
>  drivers/i2c/i2c-core-base.c           | 45 +++++++++++++++++++++++++++++++++++
>  include/linux/i2c.h                   |  3 +++
>  3 files changed, 51 insertions(+)
>
> diff --git a/Documentation/driver-model/devres.txt b/Documentation/driver-model/devres.txt
> index c180045eb..6e2bccf85 100644
> --- a/Documentation/driver-model/devres.txt
> +++ b/Documentation/driver-model/devres.txt
> @@ -259,6 +259,9 @@ GPIO
>    devm_gpio_request_one()
>    devm_gpio_free()
>
> +I2C
> +  devm_i2c_new_dummy

Please add braces here like everywhere else in this file.

With that fixed:

Reviewed-by: Bartosz Golaszewski <brgl@bgdev.pl>

@Wolfram: if you're ok with these changes, I think they should go
through my tree. Let me know if you agree.

Thanks,
Bartosz

> +
>  IIO
>    devm_iio_device_alloc()
>    devm_iio_device_free()
> diff --git a/drivers/i2c/i2c-core-base.c b/drivers/i2c/i2c-core-base.c
> index cb3f29fb8..4b05abbfa 100644
> --- a/drivers/i2c/i2c-core-base.c
> +++ b/drivers/i2c/i2c-core-base.c
> @@ -864,6 +864,51 @@ struct i2c_client *i2c_new_dummy(struct i2c_adapter *adapter, u16 address)
>  }
>  EXPORT_SYMBOL_GPL(i2c_new_dummy);
>
> +struct i2c_dummy_devres {
> +       struct i2c_client *client;
> +};
> +
> +static void devm_i2c_release_dummy(struct device *dev, void *res)
> +{
> +       struct i2c_dummy_devres *this = res;
> +
> +       i2c_unregister_device(this->client);
> +}
> +
> +/**
> + * devm_i2c_new_dummy - return a new i2c device bound to a dummy driver
> + * @dev: device the managed resource is bound to
> + * @adapter: the adapter managing the device
> + * @address: seven bit address to be used
> + * Context: can sleep
> + *
> + * This is the device-managed version of i2c_new_dummy.
> + * Note the changed return value type: It returns the new i2c client
> + * or an ERR_PTR in case of an error.
> + */
> +struct i2c_client *devm_i2c_new_dummy(struct device *dev,
> +                                     struct i2c_adapter *adapter,
> +                                     u16 address)
> +{
> +       struct i2c_dummy_devres *dr;
> +       struct i2c_client *client;
> +
> +       dr = devres_alloc(devm_i2c_release_dummy, sizeof(*dr), GFP_KERNEL);
> +       if (!dr)
> +               return ERR_PTR(-ENOMEM);
> +
> +       client = __i2c_new_dummy(adapter, address);
> +       if (IS_ERR(client)) {
> +               devres_free(dr);
> +       } else {
> +               dr->client = client;
> +               devres_add(dev, dr);
> +       }
> +
> +       return client;
> +}
> +EXPORT_SYMBOL_GPL(devm_i2c_new_dummy);
> +
>  /**
>   * i2c_new_secondary_device - Helper to get the instantiated secondary address
>   * and create the associated device
> diff --git a/include/linux/i2c.h b/include/linux/i2c.h
> index 5d7f3c185..aca6ebbb8 100644
> --- a/include/linux/i2c.h
> +++ b/include/linux/i2c.h
> @@ -441,6 +441,9 @@ extern int i2c_probe_func_quick_read(struct i2c_adapter *, unsigned short addr);
>  extern struct i2c_client *
>  i2c_new_dummy(struct i2c_adapter *adap, u16 address);
>
> +extern struct i2c_client *
> +devm_i2c_new_dummy(struct device *dev, struct i2c_adapter *adap, u16 address);
> +
>  extern struct i2c_client *
>  i2c_new_secondary_device(struct i2c_client *client,
>                                 const char *name,
> --
> 2.15.1
>
>
Wolfram Sang Dec. 18, 2017, 8:30 p.m. UTC | #2
> @Wolfram: if you're ok with these changes, I think they should go
> through my tree. Let me know if you agree.

Frankly, adding 115 lines to i2c-core should go through my tree, I
think. Still need to look at the latest revision, though.
Bartosz Golaszewski Dec. 19, 2017, 8:22 a.m. UTC | #3
2017-12-18 21:30 GMT+01:00 Wolfram Sang <wsa@the-dreams.de>:
>
>> @Wolfram: if you're ok with these changes, I think they should go
>> through my tree. Let me know if you agree.
>
> Frankly, adding 115 lines to i2c-core should go through my tree, I
> think. Still need to look at the latest revision, though.
>

Indeed, but in this case, if you pick up the whole series, you'll run
into a conflict with patch 3/3 since at24 in my tree diverged so much
from mainline.

Thanks,
Bartosz
Wolfram Sang Dec. 19, 2017, 8:28 a.m. UTC | #4
> Indeed, but in this case, if you pick up the whole series, you'll run
> into a conflict with patch 3/3 since at24 in my tree diverged so much
> from mainline.

I suggest then: if I apply the core patches, I'll send you a pull
request with an immutable branch to pull in. D'accord?
Bartosz Golaszewski Dec. 19, 2017, 8:34 a.m. UTC | #5
2017-12-19 9:28 GMT+01:00 Wolfram Sang <wsa@the-dreams.de>:
>
>> Indeed, but in this case, if you pick up the whole series, you'll run
>> into a conflict with patch 3/3 since at24 in my tree diverged so much
>> from mainline.
>
> I suggest then: if I apply the core patches, I'll send you a pull
> request with an immutable branch to pull in. D'accord?
>

Sound good.

Thanks,
Bartosz
diff mbox series

Patch

diff --git a/Documentation/driver-model/devres.txt b/Documentation/driver-model/devres.txt
index c180045eb..6e2bccf85 100644
--- a/Documentation/driver-model/devres.txt
+++ b/Documentation/driver-model/devres.txt
@@ -259,6 +259,9 @@  GPIO
   devm_gpio_request_one()
   devm_gpio_free()
 
+I2C
+  devm_i2c_new_dummy
+
 IIO
   devm_iio_device_alloc()
   devm_iio_device_free()
diff --git a/drivers/i2c/i2c-core-base.c b/drivers/i2c/i2c-core-base.c
index cb3f29fb8..4b05abbfa 100644
--- a/drivers/i2c/i2c-core-base.c
+++ b/drivers/i2c/i2c-core-base.c
@@ -864,6 +864,51 @@  struct i2c_client *i2c_new_dummy(struct i2c_adapter *adapter, u16 address)
 }
 EXPORT_SYMBOL_GPL(i2c_new_dummy);
 
+struct i2c_dummy_devres {
+	struct i2c_client *client;
+};
+
+static void devm_i2c_release_dummy(struct device *dev, void *res)
+{
+	struct i2c_dummy_devres *this = res;
+
+	i2c_unregister_device(this->client);
+}
+
+/**
+ * devm_i2c_new_dummy - return a new i2c device bound to a dummy driver
+ * @dev: device the managed resource is bound to
+ * @adapter: the adapter managing the device
+ * @address: seven bit address to be used
+ * Context: can sleep
+ *
+ * This is the device-managed version of i2c_new_dummy.
+ * Note the changed return value type: It returns the new i2c client
+ * or an ERR_PTR in case of an error.
+ */
+struct i2c_client *devm_i2c_new_dummy(struct device *dev,
+				      struct i2c_adapter *adapter,
+				      u16 address)
+{
+	struct i2c_dummy_devres *dr;
+	struct i2c_client *client;
+
+	dr = devres_alloc(devm_i2c_release_dummy, sizeof(*dr), GFP_KERNEL);
+	if (!dr)
+		return ERR_PTR(-ENOMEM);
+
+	client = __i2c_new_dummy(adapter, address);
+	if (IS_ERR(client)) {
+		devres_free(dr);
+	} else {
+		dr->client = client;
+		devres_add(dev, dr);
+	}
+
+	return client;
+}
+EXPORT_SYMBOL_GPL(devm_i2c_new_dummy);
+
 /**
  * i2c_new_secondary_device - Helper to get the instantiated secondary address
  * and create the associated device
diff --git a/include/linux/i2c.h b/include/linux/i2c.h
index 5d7f3c185..aca6ebbb8 100644
--- a/include/linux/i2c.h
+++ b/include/linux/i2c.h
@@ -441,6 +441,9 @@  extern int i2c_probe_func_quick_read(struct i2c_adapter *, unsigned short addr);
 extern struct i2c_client *
 i2c_new_dummy(struct i2c_adapter *adap, u16 address);
 
+extern struct i2c_client *
+devm_i2c_new_dummy(struct device *dev, struct i2c_adapter *adap, u16 address);
+
 extern struct i2c_client *
 i2c_new_secondary_device(struct i2c_client *client,
 				const char *name,