diff mbox series

[7/9] i2c: Switch .probe() to not take an id parameter

Message ID 20230224120600.1681685-8-u.kleine-koenig@pengutronix.de
State Superseded
Headers show
Series i2c: Switch .probe() to not take an id parameter | expand

Commit Message

Uwe Kleine-König Feb. 24, 2023, 12:05 p.m. UTC
Commit b8a1a4cd5a98 ("i2c: Provide a temporary .probe_new() call-back
type") introduced a new probe callback to convert i2c init routines to
not take an i2c_device_id parameter. Now that all in-tree drivers are
converted to the temporary .probe_new() callback, .probe() can be
modified to match the desired prototype.

Now that .probe() and .probe_new() have the same semantic, they can be
defined as members of an anonymous union to save some memory and
simplify the core code a bit.

Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
---
 drivers/i2c/i2c-core-base.c | 11 ++---------
 include/linux/i2c.h         | 14 +++++++++-----
 2 files changed, 11 insertions(+), 14 deletions(-)

Comments

Luca Ceresoli Feb. 24, 2023, 4:02 p.m. UTC | #1
Hi Uwe,

On Fri, 24 Feb 2023 13:05:58 +0100
Uwe Kleine-König         <u.kleine-koenig@pengutronix.de> wrote:

> Commit b8a1a4cd5a98 ("i2c: Provide a temporary .probe_new() call-back
> type") introduced a new probe callback to convert i2c init routines to
> not take an i2c_device_id parameter. Now that all in-tree drivers are
> converted to the temporary .probe_new() callback, .probe() can be
> modified to match the desired prototype.
> 
> Now that .probe() and .probe_new() have the same semantic, they can be
> defined as members of an anonymous union to save some memory and
> simplify the core code a bit.
> 
> Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>

Thank you, I love this cleanup!

> ---
>  drivers/i2c/i2c-core-base.c | 11 ++---------
>  include/linux/i2c.h         | 14 +++++++++-----
>  2 files changed, 11 insertions(+), 14 deletions(-)
> 
> diff --git a/drivers/i2c/i2c-core-base.c b/drivers/i2c/i2c-core-base.c
> index 087e480b624c..1fbe16221085 100644
> --- a/drivers/i2c/i2c-core-base.c
> +++ b/drivers/i2c/i2c-core-base.c
> @@ -558,15 +558,8 @@ static int i2c_device_probe(struct device *dev)
>  		goto err_detach_pm_domain;
>  	}
>  
> -	/*
> -	 * When there are no more users of probe(),
> -	 * rename probe_new to probe.
> -	 */
> -	if (driver->probe_new)
> -		status = driver->probe_new(client);
> -	else if (driver->probe)
> -		status = driver->probe(client,
> -				       i2c_match_id(driver->id_table, client));
> +	if (driver->probe)
> +		status = driver->probe(client);
>  	else
>  		status = -EINVAL;
>  
> diff --git a/include/linux/i2c.h b/include/linux/i2c.h
> index d84e0e99f084..c3e022d53182 100644
> --- a/include/linux/i2c.h
> +++ b/include/linux/i2c.h
> @@ -272,14 +272,18 @@ enum i2c_driver_flags {
>  struct i2c_driver {
>  	unsigned int class;
>  
> +	union {
>  	/* Standard driver model interfaces */
> -	int (*probe)(struct i2c_client *client, const struct i2c_device_id *id);
> +		int (*probe)(struct i2c_client *client);
> +		/*
> +		 * Legacy callback that was part of a conversion of .probe().
> +		 * Today it has the same semantic as .probe(). Don't use for new
> +		 * code.
> +		 */
> +		int (*probe_new)(struct i2c_client *client);
> +	};
>  	void (*remove)(struct i2c_client *client);
>  
> -	/* New driver model interface to aid the seamless removal of the
> -	 * current probe()'s, more commonly unused than used second parameter.
> -	 */
> -	int (*probe_new)(struct i2c_client *client);

The kerneldoc for this struct should also be updated:

- * @probe: Callback for device binding - soon to be deprecated
- * @probe_new: New callback for device binding
+ * @probe: Callback for device binding 
+ * @probe_new: Transitional callback for device binding - do not use

Otherwise LGTM.
Uwe Kleine-König Feb. 24, 2023, 6:03 p.m. UTC | #2
Hello Luca,

On Fri, Feb 24, 2023 at 05:02:18PM +0100, Luca Ceresoli wrote:
> On Fri, 24 Feb 2023 13:05:58 +0100
> Uwe Kleine-König         <u.kleine-koenig@pengutronix.de> wrote:
> > [...]
> > diff --git a/include/linux/i2c.h b/include/linux/i2c.h
> > index d84e0e99f084..c3e022d53182 100644
> > --- a/include/linux/i2c.h
> > +++ b/include/linux/i2c.h
> > @@ -272,14 +272,18 @@ enum i2c_driver_flags {
> >  struct i2c_driver {
> >  	unsigned int class;
> >  
> > +	union {
> >  	/* Standard driver model interfaces */
> > -	int (*probe)(struct i2c_client *client, const struct i2c_device_id *id);
> > +		int (*probe)(struct i2c_client *client);
> > +		/*
> > +		 * Legacy callback that was part of a conversion of .probe().
> > +		 * Today it has the same semantic as .probe(). Don't use for new
> > +		 * code.
> > +		 */
> > +		int (*probe_new)(struct i2c_client *client);
> > +	};
> >  	void (*remove)(struct i2c_client *client);
> >  
> > -	/* New driver model interface to aid the seamless removal of the
> > -	 * current probe()'s, more commonly unused than used second parameter.
> > -	 */
> > -	int (*probe_new)(struct i2c_client *client);
> 
> The kerneldoc for this struct should also be updated:
> 
> - * @probe: Callback for device binding - soon to be deprecated
> - * @probe_new: New callback for device binding
> + * @probe: Callback for device binding 
> + * @probe_new: Transitional callback for device binding - do not use

Indeed. I will send an updated patch series near the end of the merge
window, with your suggested change squashed in.

Thanks
Uwe
diff mbox series

Patch

diff --git a/drivers/i2c/i2c-core-base.c b/drivers/i2c/i2c-core-base.c
index 087e480b624c..1fbe16221085 100644
--- a/drivers/i2c/i2c-core-base.c
+++ b/drivers/i2c/i2c-core-base.c
@@ -558,15 +558,8 @@  static int i2c_device_probe(struct device *dev)
 		goto err_detach_pm_domain;
 	}
 
-	/*
-	 * When there are no more users of probe(),
-	 * rename probe_new to probe.
-	 */
-	if (driver->probe_new)
-		status = driver->probe_new(client);
-	else if (driver->probe)
-		status = driver->probe(client,
-				       i2c_match_id(driver->id_table, client));
+	if (driver->probe)
+		status = driver->probe(client);
 	else
 		status = -EINVAL;
 
diff --git a/include/linux/i2c.h b/include/linux/i2c.h
index d84e0e99f084..c3e022d53182 100644
--- a/include/linux/i2c.h
+++ b/include/linux/i2c.h
@@ -272,14 +272,18 @@  enum i2c_driver_flags {
 struct i2c_driver {
 	unsigned int class;
 
+	union {
 	/* Standard driver model interfaces */
-	int (*probe)(struct i2c_client *client, const struct i2c_device_id *id);
+		int (*probe)(struct i2c_client *client);
+		/*
+		 * Legacy callback that was part of a conversion of .probe().
+		 * Today it has the same semantic as .probe(). Don't use for new
+		 * code.
+		 */
+		int (*probe_new)(struct i2c_client *client);
+	};
 	void (*remove)(struct i2c_client *client);
 
-	/* New driver model interface to aid the seamless removal of the
-	 * current probe()'s, more commonly unused than used second parameter.
-	 */
-	int (*probe_new)(struct i2c_client *client);
 
 	/* driver model interfaces that don't relate to enumeration  */
 	void (*shutdown)(struct i2c_client *client);