diff mbox series

[V7,2/2] i2c: i2c-qcom-geni: Add shutdown callback for i2c

Message ID 20201221123801.26643-3-rojay@codeaurora.org
State Changes Requested
Headers show
Series Implement Shutdown callback for geni-i2c | expand

Commit Message

Roja Rani Yarubandi Dec. 21, 2020, 12:38 p.m. UTC
If the hardware is still accessing memory after SMMU translation
is disabled (as part of smmu shutdown callback), then the
IOVAs (I/O virtual address) which it was using will go on the bus
as the physical addresses which will result in unknown crashes
like NoC/interconnect errors.

So, implement shutdown callback to i2c driver to stop on-going transfer
and unmap DMA mappings during system "reboot" or "shutdown".

Fixes: 37692de5d523 ("i2c: i2c-qcom-geni: Add bus driver for the Qualcomm GENI I2C controller")
Signed-off-by: Roja Rani Yarubandi <rojay@codeaurora.org>
---
Changes in V2:
 - As per Stephen's comments added seperate function for stop transfer,
   fixed minor nitpicks.
 - As per Stephen's comments, changed commit text.

Changes in V3:
 - As per Stephen's comments, squashed patch 1 into patch 2, added Fixes tag.
 - As per Akash's comments, included FIFO case in stop_xfer, fixed minor nitpicks.

Changes in V4:
 - As per Stephen's comments cleaned up geni_i2c_stop_xfer function,
   added dma_buf in geni_i2c_dev struct to call i2c_put_dma_safe_msg_buf()
   from other functions, removed "iova" check in geni_se_rx_dma_unprep()
   and geni_se_tx_dma_unprep() functions.
 - Added two helper functions geni_i2c_rx_one_msg_done() and
   geni_i2c_tx_one_msg_done() to unwrap the things after rx/tx FIFO/DMA
   transfers, so that the same can be used in geni_i2c_stop_xfer() function
   during shutdown callback. Updated commit text accordingly.
 - Checking whether it is tx/rx transfer using I2C_M_RD which is valid for both
   FIFO and DMA cases, so dropped DMA_RX_ACTIVE and DMA_TX_ACTIVE bit checking

Changes in V5:
 - As per Stephen's comments, added spin_lock_irqsave & spin_unlock_irqsave in
   geni_i2c_stop_xfer() function.

Changes in V6:
 - As per Stephen's comments, taken care of unsafe lock order in
   geni_i2c_stop_xfer().
 - Moved spin_lock/unlock to geni_i2c_rx_msg_cleanup() and
   geni_i2c_tx_msg_cleanup() functions.

Changes in V7:
 - No changes 

 drivers/i2c/busses/i2c-qcom-geni.c | 35 ++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Akash Asthana Dec. 30, 2020, 9:26 a.m. UTC | #1
On 12/21/2020 6:08 PM, Roja Rani Yarubandi wrote:
> If the hardware is still accessing memory after SMMU translation
> is disabled (as part of smmu shutdown callback), then the
> IOVAs (I/O virtual address) which it was using will go on the bus
> as the physical addresses which will result in unknown crashes
> like NoC/interconnect errors.
>
> So, implement shutdown callback to i2c driver to stop on-going transfer
> and unmap DMA mappings during system "reboot" or "shutdown".
>
> Fixes: 37692de5d523 ("i2c: i2c-qcom-geni: Add bus driver for the Qualcomm GENI I2C controller")
> Signed-off-by: Roja Rani Yarubandi <rojay@codeaurora.org>
Reviewed-by: Akash Asthana <akashast@codeaurora.org>
Wolfram Sang Jan. 5, 2021, 3:27 p.m. UTC | #2
> +	geni_status = readl_relaxed(gi2c->se.base + SE_GENI_STATUS);
> +	if (!(geni_status & M_GENI_CMD_ACTIVE))
> +		goto out;
> +
> +	cur = gi2c->cur;
> +	geni_i2c_abort_xfer(gi2c);
> +	if (cur->flags & I2C_M_RD)
> +		geni_i2c_rx_msg_cleanup(gi2c, cur);
> +	else
> +		geni_i2c_tx_msg_cleanup(gi2c, cur);
> +out:
> +	pm_runtime_put_sync_suspend(gi2c->se.dev);
> +}

The use of 'goto' is not needed here IMHO. I think:

	if (geni_status & M_GENI_CMD_ACTIVE) {
		do_the_stuff
	}

	pm_runtime_put_sync_suspend(...);

is more readable, in fact. Also, I don't think we really need the 'cur'
variable and just use 'gi2c->cur' but that's very minor and you can keep
it if you like it.

Reset looks good!
Roja Rani Yarubandi Jan. 8, 2021, 9:56 a.m. UTC | #3
Hi Wolfram,

On 2021-01-05 20:57, Wolfram Sang wrote:
>> +	geni_status = readl_relaxed(gi2c->se.base + SE_GENI_STATUS);
>> +	if (!(geni_status & M_GENI_CMD_ACTIVE))
>> +		goto out;
>> +
>> +	cur = gi2c->cur;
>> +	geni_i2c_abort_xfer(gi2c);
>> +	if (cur->flags & I2C_M_RD)
>> +		geni_i2c_rx_msg_cleanup(gi2c, cur);
>> +	else
>> +		geni_i2c_tx_msg_cleanup(gi2c, cur);
>> +out:
>> +	pm_runtime_put_sync_suspend(gi2c->se.dev);
>> +}
> 
> The use of 'goto' is not needed here IMHO. I think:
> 
> 	if (geni_status & M_GENI_CMD_ACTIVE) {
> 		do_the_stuff
> 	}
> 
> 	pm_runtime_put_sync_suspend(...);
> 
> is more readable, in fact.
> 

In context to the previous comment [1], I have implemented this way.
But, yeah anything is fine for me.

> Also, I don't think we really need the 'cur'
> variable and just use 'gi2c->cur' but that's very minor and you can 
> keep
> it if you like it.
> 

In geni_i2c_abort_xfer() function gi2c->cur will be made NULL, so 
copying it before to "cur" is needed here.

> Reset looks good!

[1] 
https://patchwork.kernel.org/project/linux-arm-msm/patch/20200820103522.26242-3-rojay@codeaurora.org/#23560541

Thanks,
Roja
Wolfram Sang Jan. 8, 2021, 10:06 a.m. UTC | #4
> > The use of 'goto' is not needed here IMHO. I think:
...
> In context to the previous comment [1], I have implemented this way.
> But, yeah anything is fine for me.

Thanks, I really think it is better.

> In geni_i2c_abort_xfer() function gi2c->cur will be made NULL, so copying it
> before to "cur" is needed here.

Okay then, thanks for the heads up!
diff mbox series

Patch

diff --git a/drivers/i2c/busses/i2c-qcom-geni.c b/drivers/i2c/busses/i2c-qcom-geni.c
index 214b4c913a13..7903e6145543 100644
--- a/drivers/i2c/busses/i2c-qcom-geni.c
+++ b/drivers/i2c/busses/i2c-qcom-geni.c
@@ -375,6 +375,33 @@  static void geni_i2c_tx_msg_cleanup(struct geni_i2c_dev *gi2c,
 	}
 }
 
+static void geni_i2c_stop_xfer(struct geni_i2c_dev *gi2c)
+{
+	int ret;
+	u32 geni_status;
+	struct i2c_msg *cur;
+
+	/* Resume device, as runtime suspend can happen anytime during transfer */
+	ret = pm_runtime_get_sync(gi2c->se.dev);
+	if (ret < 0) {
+		dev_err(gi2c->se.dev, "Failed to resume device: %d\n", ret);
+		return;
+	}
+
+	geni_status = readl_relaxed(gi2c->se.base + SE_GENI_STATUS);
+	if (!(geni_status & M_GENI_CMD_ACTIVE))
+		goto out;
+
+	cur = gi2c->cur;
+	geni_i2c_abort_xfer(gi2c);
+	if (cur->flags & I2C_M_RD)
+		geni_i2c_rx_msg_cleanup(gi2c, cur);
+	else
+		geni_i2c_tx_msg_cleanup(gi2c, cur);
+out:
+	pm_runtime_put_sync_suspend(gi2c->se.dev);
+}
+
 static int geni_i2c_rx_one_msg(struct geni_i2c_dev *gi2c, struct i2c_msg *msg,
 				u32 m_param)
 {
@@ -650,6 +677,13 @@  static int geni_i2c_remove(struct platform_device *pdev)
 	return 0;
 }
 
+static void  geni_i2c_shutdown(struct platform_device *pdev)
+{
+	struct geni_i2c_dev *gi2c = platform_get_drvdata(pdev);
+
+	geni_i2c_stop_xfer(gi2c);
+}
+
 static int __maybe_unused geni_i2c_runtime_suspend(struct device *dev)
 {
 	int ret;
@@ -714,6 +748,7 @@  MODULE_DEVICE_TABLE(of, geni_i2c_dt_match);
 static struct platform_driver geni_i2c_driver = {
 	.probe  = geni_i2c_probe,
 	.remove = geni_i2c_remove,
+	.shutdown = geni_i2c_shutdown,
 	.driver = {
 		.name = "geni_i2c",
 		.pm = &geni_i2c_pm_ops,