mbox series

[GIT,PULL] intel-gpio for 5.12-1

Message ID YBqOQpaTpUbDcdKo@black.fi.intel.com
State New
Headers show
Series [GIT,PULL] intel-gpio for 5.12-1 | expand

Pull-request

git@gitolite.kernel.org:pub/scm/linux/kernel/git/andy/linux-gpio-intel.git tags/intel-gpio-v5.12-1

Message

Andy Shevchenko Feb. 3, 2021, 11:51 a.m. UTC
Hi Linux GPIO  maintainers,

Non-traditional bunch for Intel GPIO drivers, because it includes an aggregator
clean up with necessary libraries update and test cases. Besides that, it has
nothing special, except removing couple of drivers from the subsystem. In any
case this PR is independent, but would be nice to couple it with PR of
ib-drm-gpio-pdx86-rtc-wdt-v5.12-1 which I had sent couple of weeks earlier.

Thanks,

With Best Regards,
Andy Shevchenko

The following changes since commit 5c8fe583cce542aa0b84adc939ce85293de36e5e:

  Linux 5.11-rc1 (2020-12-27 15:30:22 -0800)

are available in the Git repository at:

  git@gitolite.kernel.org:pub/scm/linux/kernel/git/andy/linux-gpio-intel.git tags/intel-gpio-v5.12-1

for you to fetch changes up to c5318e248f527fc8753e361bb61439f4e0c6d745:

  gpio: msic: Drop driver from Makefile (2021-02-03 13:05:56 +0200)

----------------------------------------------------------------
intel-gpio for v5.12-1

* Use generic parser of the ranges in GPIO aggregator driver
* Clean up Whiskey Cove driver to use new APIs and drop ambiguous casting
* Remove couple of drivers for deprecated platforms

The following is an automated git shortlog grouped by driver:

aggregator:
 -  Remove trailing comma in terminator entries
 -  Use compound literal from the header
 -  Replace isrange() by using get_options()

intel-mid:
 -  Remove driver for deprecated platform

lib/cmdline:
 -  Allow get_options() to take 0 to validate the input
 -  Update documentation to reflect behaviour

lib/cmdline_kunit:
 -  add a new test case for get_options()

merrifield:
 -  Make bias configuration available for GPIOs

msic:
 -  Drop driver from Makefile
 -  Remove driver for deprecated platform

wcove:
 -  Split out to_ireg() helper and deduplicate the code
 -  Switch to use regmap_set_bits(), regmap_clear_bits()
 -  Get rid of error prone casting in IRQ handler
 -  convert comma to semicolon

----------------------------------------------------------------
Andy Shevchenko (13):
      gpio: merrifield: Make bias configuration available for GPIOs
      lib/cmdline_kunit: add a new test case for get_options()
      lib/cmdline: Update documentation to reflect behaviour
      lib/cmdline: Allow get_options() to take 0 to validate the input
      gpio: aggregator: Replace isrange() by using get_options()
      gpio: aggregator: Use compound literal from the header
      gpio: aggregator: Remove trailing comma in terminator entries
      gpio: msic: Remove driver for deprecated platform
      gpio: intel-mid: Remove driver for deprecated platform
      gpio: wcove: Get rid of error prone casting in IRQ handler
      gpio: wcove: Switch to use regmap_set_bits(), regmap_clear_bits()
      gpio: wcove: Split out to_ireg() helper and deduplicate the code
      gpio: msic: Drop driver from Makefile

Zheng Yongjun (1):
      gpio: wcove: convert comma to semicolon

 MAINTAINERS                    |   2 -
 drivers/gpio/Kconfig           |  14 --
 drivers/gpio/Makefile          |   2 -
 drivers/gpio/TODO              |   2 +-
 drivers/gpio/gpio-aggregator.c |  40 +---
 drivers/gpio/gpio-intel-mid.c  | 414 -----------------------------------------
 drivers/gpio/gpio-merrifield.c |   5 +
 drivers/gpio/gpio-msic.c       | 314 -------------------------------
 drivers/gpio/gpio-wcove.c      |  65 +++----
 include/linux/gpio/machine.h   |   4 +-
 lib/cmdline.c                  |  21 ++-
 lib/cmdline_kunit.c            |  56 ++++++
 12 files changed, 120 insertions(+), 819 deletions(-)
 delete mode 100644 drivers/gpio/gpio-intel-mid.c
 delete mode 100644 drivers/gpio/gpio-msic.c

Comments

Bartosz Golaszewski Feb. 5, 2021, 8:59 a.m. UTC | #1
On Wed, Feb 3, 2021 at 12:55 PM Andy Shevchenko
<andriy.shevchenko@linux.intel.com> wrote:
>
> Hi Linux GPIO  maintainers,
>
> Non-traditional bunch for Intel GPIO drivers, because it includes an aggregator
> clean up with necessary libraries update and test cases. Besides that, it has
> nothing special, except removing couple of drivers from the subsystem. In any
> case this PR is independent, but would be nice to couple it with PR of
> ib-drm-gpio-pdx86-rtc-wdt-v5.12-1 which I had sent couple of weeks earlier.
>
> Thanks,
>
> With Best Regards,
> Andy Shevchenko
>

Pulled in, thanks!

Bartosz